1

I'm working with QGIS and trying to change the CRS of some maps. Is is possible to do it without the .prj file?

3
  • QGIS automatically creates a new .prj file if you change the CRS. However you need to know the original CRS (the name is enough) in order to make a reprojection. – Curlew Aug 20 '13 at 17:29
  • 1
    The thing is that I downloaded several maps from the National Geography Institute of Mexico but they only have available the .dbf,.shp and .shx files, not the .prj one. I opened them on QGIS and tried to change the CRS to WGS84 (by saving it as with other name and specifying the new CRS) but when opening the saved file, on the properties table it says that the CRS is WGS84 but the CRS values do not correspond. When I try to project them with other files that have WGS84 as CRS I can't see them. Do you have any tip that I could use?! – user20159 Aug 20 '13 at 17:37
  • 1
    Before you do the "Save As" step, open the original shape's properties, metadata tab, and check what CRS is applied to the original. As Curlew said, you must know in advance which CRS the original is in before doing any reprojecting. If the layer CRS is not recognized correctly by QGIS you have to "declare" it's CRS, in the Properties window, CRS tab. – Micha Aug 20 '13 at 18:07
1

You have to take in to account somethings. INEGI (National Geoography Instutute of Mexico) has data in UTM, Lambert Conformal Conic (this one with special parameters)and some in lat lon unprojected. Also You can get the data in NAD27 or ITRF92 datums. As Curlew says, before doing any reprojection you must know the layer original crs. I don know why INEGI does not provide sometimes the prj file but stores the CRS information in a text file. Find the text file and check the CRS information.

Bear in mind also that if the layer is in NAD27 you have to know the parameters for the wgs84 transformation. According to NIMA (2000), Department of Defense, World Geodetic System 1984: Its Definition and Relationships with local Geodetic Sytems, appendix B 6.5 the parameters are:

+towgs84=-12,130,190,0,0,0,0

If the layers is in ITRF92 datum (either UTM, LCC or latlon) You will not find a CRS based on ITRF92 datm in QGIS (UTM. LCC or latlon). INEGI suggest that if your goal is to produce a map in a scale smaller than 1:50,000 you can use a WGS84 datum.

If the layer is in LCC you have to make the INEGI LCC CRS and store it in QGIS as a User defined CRS. The parameters are:

+proj=lcc +lat_1=17.5 +lat_2=29.5 +lat_0=12 +lon_0=-102 +x_0=2500000 +y_0=0 +ellps=WGS84 +datum=WGS84 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs

Hope it helps

Gerardo

1
  • Thanks everyone for the help. I got it now. I'm not quite sure if I did what you meant but is finally SOLVED!. I just projected the map, change the CRS to user defined (there was already an option there, from previous maps) then saved it as specifying the new CRS (WGS84). I was doing the same but without changing the CRS to user defined :) ! – user20159 Aug 21 '13 at 16:31
2

You can always set the CRS of a layer with rightclick on the layer -> Set CRS for Layer. After that, you can reproject the data with Save As...

If you have this case of missing .prj file often, deactivate the CRS preset in Settings -> Options -> CRS tab. there you can specify that QGIS should ask for a CRS if no .prj is present. In your configuration, the default may be set to WGS84 or to Layer of the project, which gives you wrong data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.