0

I am afraid I am quite new to spatial analysis at anything beyond a superficial level, and I have only recently transitioned to utilizing R. I have been quite pleased with the versatility of areal analysis, but I have just attempted to load my first point layer.

In a nutshell, it's taking much, much longer than anticipated. I first tried to use readShapeSpatial (from maptools I believe), but I read somewhere that readOGR (from rgdal) was faster. I let readShapeSpatial run for over an hour before killing it, and now readOGR has been running for at least 20 minutes.

Here is the line:

c<-readOGR('/home/.../DCSpatialAnalysis','CamaRes.shp')

The data attribute houses a frame containing character and numeric data. There are 106,046 records and 46 columns. The file size is only ~75MB (including the all elements of the shapefile).

I do not believe my hardware is underpowered for this task (though I am always happy with more horsepower):

OS: Ubuntu 13.04 (VMWare) on Windows 7

Make/Model: Dell/OptiPlex 790

Processor: i3 (3.3 GHz)

RAM: 16 GB installed

I should mention that I have been able to successfully parse and display an XML document from within my IPython Notebook session that resides in the same directory. That suggests, to me, that reading from a mounted directory is not an issue.

Have I done something incorrectly here? R seems to just hang in the "Busy" status, both in RStudio and IPython Notebook (via %rmagic). How long should such a read in take?

closed as off-topic by Curlew, Paul, PolyGeo, BradHards, Fezter Nov 2 '13 at 3:32

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Paul, PolyGeo, BradHards, Fezter
If this question can be reworded to fit the rules in the help center, please edit the question.

  • That does seem too long for a file that size. I am on Windows, but if I have a problem like this I check the R process and kill others that might be using processor time, though my hardware is less powerful than yours. I take it this shapefile is proprietary and thus can't be checked by others? – SlowLearner Aug 23 '13 at 7:33
  • Unfortunately you are correct. We are not allowed to share this information. However, I have tried some publicly available data, as I describe in the close out to this question below. – Marvin Ward Jr Aug 23 '13 at 22:38
1

It turns out that I have successfully loaded a publicly available point layer on my home machine (Ubuntu 13.04) fairly quickly. (I used the CamaResPt.shp layer provided by DC GIS). This leads me to believe that an issue is actually being caused by VMWare (despite my earlier suggestion). In any event, this question is no longer relevant in its current form.

Not the answer you're looking for? Browse other questions tagged or ask your own question.