6

From what I understand, the default port for ArcGIS for Server is port 6080. I have installed ArcGIS for Server 10.2 and now I cannot connect to the Server Manager. I am using Windows 8. My firewall is completely turned off. I have restarted the service about 100 times and I have reinstalled ArcGIS for Server about 10 times at this point. The port is not shown when I do a netstat -an in command prompt as well. Any help would be appreciated. Thank you in advance.

URL I used: http://localhost:6080/arcgis/manager

Picture of "error":

In Chrome

In FireFox

In IE

5

If the service claims to be running with nothing logged in event viewer and nothing shows up in netstat -ano | find "6080" maybe its been configured to run on another port or isn't listening at all.

Right-click the service (in the services.msc list) and go to Properties to find the name of the .exe it runs like if its arc.exe then do this in command prompt to see what Process ID the service is running as...:

tasklist /svc | find "arc.exe"

Then you can do the following to see which port(s) the service is listening on, if any:

netstat -ano | find "<PID>"

example:

H:\>netstat -ano | find "11144"
  TCP    0.0.0.0:6099           0.0.0.0:0              LISTENING       11144
  TCP    0.0.0.0:52945          0.0.0.0:0              LISTENING       11144
  TCP    (Ip Address):52945   :52947   ESTABLISHED     11144
  TCP    (IP Address):52947   52945   ESTABLISHED     11144
  TCP    [::]:6099              [::]:0                 LISTENING       11144
  TCP    [::]:52945             [::]:0                 LISTENING       11144

In the example above, the PID 11144 is listening on port 6099, instead of what you expect the 6080.

Thus, you should be able to access it via: http://localhost:6099/arcgis/manager

  • Still did not work... And in order for me to get the Web Adapter to work, I have to get connected to the manager. It works on my Windows 7 VM but will not work on my local which is running Windows 8. ESRI does claim that it will run on Windows 8 though. – JLott Sep 4 '13 at 13:41
2

Make sure the machine you are accessing at localhost:6080/arcgis/manager IS the server?
If not, then use the IP address 123.456.7.8:6080/arcgis/manager or the machine name mymachine:6080/arcgis/manager.

If that doesn't work, check the service on the server machine to make sure ArcGIS Server started.
If it is running, then check IIS to make sure you don't have https required on the ArcGIS app.
If none of that works, post back here (edit your original question) with further info on what you have found.
Are you successful if you try myserver:6080/ArcGIS/rest/admin?

  • I am still not successful. (Sorry for the delayed post I work M-F.) Like I said, my computer is not even listening to port 6080. From what I understand ArcGIS server should open port 6080... – JLott Aug 26 '13 at 13:29
  • please edit your original question with more information about "your computer" "the server" "the network you are on" and where you have done what and what you have tried. If you have the web adaptor installed or have attempted to install it. – Brad Nesom Aug 26 '13 at 13:44
1

the solution that worked was me... give administrative privileges to the Windows account ArcGIS , and restart the service ArcGIS Server in services.msc

0

Arcgis Server Working

IF server working like on the picture http://localhost:6080/arcgis you can fallow next step.

I had have the same problem with login to http://localhost:6080/arcgis/manager/ in Windows 8 Professional. After installing Arcgis Server please use http://localhost:6080/arcgis/admin.

  1. Create new server site.
  2. Try login to http://localhost:6080/arcgis/admin with login and passwd from server site account even during account cretion error occured.
  3. Try login to http://localhost:6080/arcgis/manager with login and passwd from server site account.

You should see very quick login panel :) Congratulations!!!

  • I am still getting the same error when I try this. Thank you for trying to help though. I will remember this for future use. – JLott Sep 9 '13 at 13:26
0

enter image description herei think this will be solution for this problem as follows ..

restart the server Once.

0

Thank you all for posting. I had a slightly different spin on the problem based on the 10.5.1 builder install that includes portal, arcgis server, and the web adapters. My message was

The Web Adaptor URL https://myserver.server cannot be reached. Please check that https has been enabled for your web server...

I had a different System Admin set up the server operating system verses my prior install that went swimmingly well. The netstat -ano | find "<PID>" was a great help during trouble shooting. The long story short is that IIS was not configured with the https port 443 binding. The interesting note is that you do not have to enable port 6443 as a binding in IIS Manager application to fix the problem. Once, I enable the https/443 binding, I was able to proceed with a normal install. Now from my experience with 10.5.1, I will be first running all the program uninstalls before I attempt to reinstall the Esri server with the builder 10.5.1 software. Strange things can happen that will still affect your installation. As always, I hope this helps someone in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.