There is the ArcGis Server on the machine 192.168.**.22

Machine name is MAPSERVER.

User name and password for ArcgIS Server are "test" and "testtest" (for example)

ArcGis Server options are: clusters - name "default", computer "MAPSEVER", protocol "TCP port 4004".

I want to connect to this ArcGis Server. I used code

ESRI.ArcGIS.ADF.Identity identity = new ESRI.ArcGIS.ADF.Identity("test", "testtest", "default");
ESRI.ArcGIS.ADF.Connection.AGS.AGSServerConnection agsconnection;
agsconnection = new ESRI.ArcGIS.ADF.Connection.AGS.AGSServerConnection("MAPSERVER", identity);
IServerObjectManager SOM = agsconnection.ServerObjectManager; 

I get error `

"Identity error"

  • Few questions to you 1.Which version you are using (I think you are using 10.0)2.Are you want to make connection using ADF ?3.Is there same license level for both machines? (like Advance-Advance) 4.Both machines have same versions for AGS? 5.Is there any firewall enabled between two machine?
    – Sunil
    Commented Aug 23, 2013 at 9:44
  • 1) ArcGis Desktop 10.1, license: ArcInfo - floating license (on my machine); ArcGis Server 10.1, ArcGis Desktop 10.1, license: ArcInfo - floating license (on server). 2) No. It is not principle. 3) Yes 4) Yes 5) No
    – novicegis
    Commented Aug 23, 2013 at 9:55
  • Could you please explain your question in detail? Because I was wondering that how you are connecting the ArcGIS Server (Through code/some application/desktop,Arc Catalog etc) & I guess that your machine have only the code and through that code you are connecting the AGS server is that correct?
    – Sunil
    Commented Aug 23, 2013 at 10:10
  • I do not know what kind of information do I need to substitute at domain, host, password, user.
    – novicegis
    Commented Aug 23, 2013 at 10:34

1 Answer 1


The web ADF was discontinued in 10.0 and above. The help you cited was from the 9.3 help. Now ESRI wants you to use either Geoprocessing models or Server Object Extensions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.