I have some tiles of OS raster mapping and their associated TFW georeferencing files. The GR files are in the same folder as the raster data and have the same names, ie TQ21.tif/TQ21.tfw.

In QGIS 1.8, I add a tile as a raster layer and choose the OSGB 1936/British National Grid CRS. When I load the next tile over, it loads in the correct place. Fine so far.

However, the problem is that the scale is completely out - to view a tile I have the onscreen scale indicator at around 1:365000000! If I go to Raster > Miscellaneous > Information there is nothing in the Raster Info box, but the fact that the tiles load in their correct place suggests QGIS is reading the GR files.

Am I missing something?

  • I have actually just partially solved this by creating a Virtual Raster of the whole 100km grid square, but I guess it would still be useful to know how to set the scale of one or two raster tiles. – ElendilTheTall Aug 26 '13 at 11:40
  • 2
    Set the layer CRS to EPSG:27700. – nhopton Aug 26 '13 at 12:39

Make sure the project CRS is set to EPSG:27700 as well. The project CRS by default is WGS84. You can set the project CRS by right-clicking on a layer with a CRS of EPSG:27700 and select 'Set Project CRS from Layer'. You will probably have to Zoom To Layer after changing these settings. The best option is to set your project default CRS to 27700 if you are working mostly with UK OS data and it will save you some trouble (Go Settings->Options->CRS). I use these data regularly in this way and the scale shows correctly.

| improve this answer | |

I think you got into troubles because in Settings -> Optios -> CRS tab

CRS for new layers is set to Project CRS or Default CRS.

The safest way is to set this option to Prompt for CRS.

Whenever you get a raster without CRS information, you will be asked, and think about what is right. A default to WGS84 will be wrong in most cases.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.