I am using QGIS 1.9 master with Ubuntu 13.04. I tried to use the SAGA hydrology tools in sextante today and it said they did not appeared to be installed. I checked and sure enough SAGA was indeed installed.

I did some searching and found out I need to update SAGA to version 2.1. I added the unofficial ppa (ppa:johanvdw/saga-gis) and ran sudo apt-get update and tried to install. I get a message telling me it is already installed. So I uninstalled 2.0.8 and tried again. It just reinstalled 2.0.8. I tried targeting the install sudo apt-get install -t saga-gis saga. it told me there was no saga-gis. I opened the synaptic package handler to choose the packages manually and nothing shows up their either. However, when I look at the software and updates section I can clearly see the added repository and according to the launchpad site their is a raring version. Here is a picture showing synaptic.enter image description here Any ideas??

  • As I haven't installed SAGA, I can't comment on your issue. I can only suggest that you can try installing the same from source using these instructions
    – Chethan S.
    Commented Sep 1, 2013 at 7:48

1 Answer 1


Try the following commands from a command line:

sudo add-apt-repository ppa:johanvdw/saga-gis
sudo apt-get update
sudo apt-get install saga

The problem may be that synaptic has not updated it sources because the signing key was not imported. This should be the most easy way to fix that error.

[update] It seems the wxwidgets package for raring was uploaded but not build for some reason. This is now fixed. You should be able to install saga on raring.

  • I had done all of that and still nothing. It's like the files from the ppa are not being added to the list. I just realized you are the person who runs the PPA, Hello :)
    – G.Oxsen
    Commented Sep 2, 2013 at 17:30
  • PPA is fixed, install should work fine now.
    – johanvdw
    Commented Sep 4, 2013 at 12:55
  • Thank you so much! I turned on my software updater today and everything installed.
    – G.Oxsen
    Commented Sep 4, 2013 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.