1

I'm attempting to install postgis2 on RHEL 6.4 by using the instructions postgis.net/install, but after the postgis2 install, neither initdb nor /etc/init.d/postgreql92 is present. The same thing happens with the 9.3 beta. Is a source installation my best option?

DETAILS

[root@pgsrv ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.4 (Santiago)

[root@pgsrv ~]# rpm -qa | grep post
postfix-2.6.6-2.2.el6_1.x86_64

[root@pgsrv ~]# rpm -qa | grep pgdg

[root@pgsrv ~]# rpm -ihv pgdg-redhat92-9.2-7.noarch.rpm
Preparing...                ########################################### [100%]
   1:pgdg-redhat92          ########################################### [100%]

[root@pgsrv ~]# cd /etc/yum/pluginconf.d/
[root@pgsrv pluginconf.d]# ls
changelog.conf               product-id.conf          security.conf              versionlock.conf
downloadonly.conf            rhnplugin.conf           subscription-manager.conf  versionlock.list
epel-release-6-8.noarch.rpm  rhnplugin.conf-original  verify.conf
[root@pgsrv pluginconf.d]# cat rhnplugin.conf
[main]
enabled = 1
gpgcheck = 1

# Added "exclude=postgresql*" for PostGIS 
exclude=postgresql*

# You can specify options per channel, e.g.:
#
#[rhel-i386-server-5]
#enabled = 1
#
#[some-unsigned-custom-channel]
#gpgcheck = 0


[root@pgsrv pluginconf.d]# yum install postgis2*
Loaded plugins: changelog, downloadonly, product-id, rhnplugin, security, verify, versionlock
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package postgis2_92.x86_64 0:2.0.3-2.rhel6 will be installed
--> Processing Dependency: postgresql92 for package: postgis2_92-2.0.3-2.rhel6.x86_64
--> Processing Dependency: libpq.so.5()(64bit) for package: postgis2_92-2.0.3-2.rhel6.x86_64
--> Processing Dependency: libgdal.so.1()(64bit) for package: postgis2_92-2.0.3-2.rhel6.x86_64
---> Package postgis2_92-debuginfo.x86_64 0:2.0.3-2.rhel6 will be installed
---> Package postgis2_92-devel.x86_64 0:2.0.3-2.rhel6 will be installed
---> Package postgis2_92-docs.x86_64 0:2.0.3-2.rhel6 will be installed
---> Package postgis2_92-utils.x86_64 0:2.0.3-2.rhel6 will be installed
--> Processing Dependency: perl-DBD-Pg for package: postgis2_92-utils-2.0.3-2.rhel6.x86_64
--> Running transaction check
---> Package gdal.x86_64 0:1.7.3-15.el6 will be installed
---> Package perl-DBD-Pg.x86_64 0:2.15.1-4.el6_3 will be installed
---> Package postgresql92.x86_64 0:9.2.4-1PGDG.rhel6 will be installed
---> Package postgresql92-libs.x86_64 0:9.2.4-1PGDG.rhel6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================
 Package                          Arch              Version                       Repository                       Size
========================================================================================================================
Installing:
 postgis2_92                      x86_64            2.0.3-2.rhel6                 pgdg92                          2.5 M
 postgis2_92-debuginfo            x86_64            2.0.3-2.rhel6                 pgdg92                          1.5 M
 postgis2_92-devel                x86_64            2.0.3-2.rhel6                 pgdg92                          172 k
 postgis2_92-docs                 x86_64            2.0.3-2.rhel6                 pgdg92                          3.7 M
 postgis2_92-utils                x86_64            2.0.3-2.rhel6                 pgdg92                           31 k
Installing for dependencies:
 gdal                             x86_64            1.7.3-15.el6                  epel                            3.0 M
 perl-DBD-Pg                      x86_64            2.15.1-4.el6_3                rhel-x86_64-server-6            196 k
 postgresql92                     x86_64            9.2.4-1PGDG.rhel6             pgdg92                          970 k
 postgresql92-libs                x86_64            9.2.4-1PGDG.rhel6             pgdg92                          185 k

Transaction Summary
========================================================================================================================
Install       9 Package(s)

Total download size: 12 M
Installed size: 53 M
Is this ok [y/N]: y
Downloading Packages:
(1/9): gdal-1.7.3-15.el6.x86_64.rpm                                                              | 3.0 MB     00:00     
(2/9): perl-DBD-Pg-2.15.1-4.el6_3.x86_64.rpm                                                     | 196 kB     00:00     
(3/9): postgis2_92-2.0.3-2.rhel6.x86_64.rpm                                                      | 2.5 MB     00:00     
(4/9): postgis2_92-debuginfo-2.0.3-2.rhel6.x86_64.rpm                                            | 1.5 MB     00:00     
(5/9): postgis2_92-devel-2.0.3-2.rhel6.x86_64.rpm                                                | 172 kB     00:00     
(6/9): postgis2_92-docs-2.0.3-2.rhel6.x86_64.rpm                                                 | 3.7 MB     00:00     
(7/9): postgis2_92-utils-2.0.3-2.rhel6.x86_64.rpm                                                |  31 kB     00:00     
(8/9): postgresql92-9.2.4-1PGDG.rhel6.x86_64.rpm                                                 | 970 kB     00:00     
(9/9): postgresql92-libs-9.2.4-1PGDG.rhel6.x86_64.rpm                                            | 185 kB     00:00     
------------------------------------------------------------------------------------------------------------------------
Total                                                                                   9.2 MB/s |  12 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : postgresql92-libs-9.2.4-1PGDG.rhel6.x86_64                                                           1/9 
  Installing : postgresql92-9.2.4-1PGDG.rhel6.x86_64                                                                2/9 
  Installing : gdal-1.7.3-15.el6.x86_64                                                                             3/9 
  Installing : postgis2_92-2.0.3-2.rhel6.x86_64                                                                     4/9 
  Installing : perl-DBD-Pg-2.15.1-4.el6_3.x86_64                                                                    5/9 
  Installing : postgis2_92-utils-2.0.3-2.rhel6.x86_64                                                               6/9 
  Installing : postgis2_92-devel-2.0.3-2.rhel6.x86_64                                                               7/9 
  Installing : postgis2_92-docs-2.0.3-2.rhel6.x86_64                                                                8/9 
  Installing : postgis2_92-debuginfo-2.0.3-2.rhel6.x86_64                                                           9/9 
  Verifying  : postgis2_92-debuginfo-2.0.3-2.rhel6.x86_64                                                           1/9 
  Verifying  : postgis2_92-docs-2.0.3-2.rhel6.x86_64                                                                2/9 
  Verifying  : postgis2_92-devel-2.0.3-2.rhel6.x86_64                                                               3/9 
  Verifying  : postgresql92-libs-9.2.4-1PGDG.rhel6.x86_64                                                           4/9 
  Verifying  : postgis2_92-2.0.3-2.rhel6.x86_64                                                                     5/9 
  Verifying  : postgresql92-9.2.4-1PGDG.rhel6.x86_64                                                                6/9 
  Verifying  : postgis2_92-utils-2.0.3-2.rhel6.x86_64                                                               7/9 
  Verifying  : gdal-1.7.3-15.el6.x86_64                                                                             8/9 
  Verifying  : perl-DBD-Pg-2.15.1-4.el6_3.x86_64                                                                    9/9 

Installed:
  postgis2_92.x86_64 0:2.0.3-2.rhel6                       postgis2_92-debuginfo.x86_64 0:2.0.3-2.rhel6                
  postgis2_92-devel.x86_64 0:2.0.3-2.rhel6                 postgis2_92-docs.x86_64 0:2.0.3-2.rhel6                     
  postgis2_92-utils.x86_64 0:2.0.3-2.rhel6                

Dependency Installed:
  gdal.x86_64 0:1.7.3-15.el6                               perl-DBD-Pg.x86_64 0:2.15.1-4.el6_3                          
  postgresql92.x86_64 0:9.2.4-1PGDG.rhel6                  postgresql92-libs.x86_64 0:9.2.4-1PGDG.rhel6                 

Complete!

[root@pgsrv pluginconf.d]# cd /usr/
[root@pgsrv usr]# cd pgsql-9.2
[root@pgsrv pgsql-9.2]# cd bin
[root@pgsrv bin]# ls
clusterdb   createuser  dropuser       pg_dump         pg_restore     psql          shp2pgsql
createdb    dropdb      pg_basebackup  pg_dumpall      pgsql2shp      raster2pgsql  vacuumdb
createlang  droplang    pg_config      pg_receivexlog  pg_test_fsync  reindexdb

[root@pgsrv bin]# cd /etc/init.d
[root@pgsrv init.d]# ls
abrt-ccpp         cgconfig   iptables      network                 postgresql-9.3.rpmsave  rpcsvcgssd      trace-cmd
abrtd             cgred      irqbalance    nfs                     psacct                  rsyslog         tuned
abrt-oops         crond      kdump         nfslock                 qpidd                   sandbox         udev-post
acpid             cups       killall       nscd                    quota_nld               saslauthd       wdaemon
arptables_jf      dbora      ktune         nslcd                   rdisc                   single          winbind
arpwatch          dovecot    lvm2-lvmetad  ntpd                    restorecond             spamassassin    xinetd
atd               firstboot  lvm2-monitor  ntpdate                 rhnsd                   spice-vdagentd
auditd            functions  mcelogd       oddjobd                 rhsmcertd               sshd
autofs            haldaemon  mdmonitor     portreserve             rngd                    svnserve
avahi-daemon      halt       messagebus    postfix                 rpcbind                 sysstat
blk-availability  ip6tables  netconsole    postgresql-9.3-data-pg  rpcgssd                 systemtap
certmonger        ipsec      netfs         postgresql-9.3-orig     rpcidmapd               tcsd

[root@pgsrv init.d]# yum provides */initdb
Loaded plugins: changelog, downloadonly, product-id, rhnplugin, security, verify, versionlock
This system is receiving updates from RHN Classic or RHN Satellite.
elrepo-s6-x86_64/filelists                                                                       | 132 kB     00:00     
epel/filelists_db                                                                                | 7.6 MB     00:07     
pgdg92/filelists_db                                                                              | 157 kB     00:00     
rhel-x86_64-server-6/filelists                                                                   |  25 MB     00:03     
rhel-x86_64-server-optional-6/filelists                                                          | 9.3 MB     00:01     
rhel-x86_64-server-supplementary-6/filelists                                                     | 1.4 MB     00:00     
rhn-tools-rhel-x86_64-server-6/filelists                                                         |  57 kB     00:00     
postgresql92-server-9.2.4-1PGDG.rhel6.x86_64 : The programs needed to create and run a PostgreSQL server
Repo        : pgdg92
Matched from:
Filename    : /usr/pgsql-9.2/bin/initdb

postgresql92-debuginfo-9.2.3-2PGDG.rhel6.x86_64 : Debug information for package postgresql92
Repo        : pgdg92
Matched from:
Filename    : /usr/src/debug/postgresql-9.2.3/src/bin/initdb

postgresql92-server-9.2.3-2PGDG.rhel6.x86_64 : The programs needed to create and run a PostgreSQL server
Repo        : pgdg92
Matched from:
Filename    : /usr/pgsql-9.2/bin/initdb

postgresql92-debuginfo-9.2.4-1PGDG.rhel6.x86_64 : Debug information for package postgresql92
Repo        : pgdg92
Matched from:
Filename    : /usr/src/debug/postgresql-9.2.4/src/bin/initdb

[root@pgsrv init.d]# rpm -qa | grep post
postgis2_92-docs-2.0.3-2.rhel6.x86_64
postgresql92-9.2.4-1PGDG.rhel6.x86_64
postgis2_92-utils-2.0.3-2.rhel6.x86_64
postgis2_92-devel-2.0.3-2.rhel6.x86_64
postfix-2.6.6-2.2.el6_1.x86_64
postgis2_92-2.0.3-2.rhel6.x86_64
postgresql92-libs-9.2.4-1PGDG.rhel6.x86_64
postgis2_92-debuginfo-2.0.3-2.rhel6.x86_64

[root@pgsrv init.d]# rpm -ql postgis2_92| grep initdb
[root@pgsrv init.d]# rpm -ql postgis2_92 | wc
    239     239   14920
[root@pgsrv init.d]# 
[root@pgsrv init.d]# rpm -ql postgresql92 | wc
    327     327   15799
[root@pgsrv init.d]# rpm -ql postgresql92 | grep initdb
/usr/pgsql-9.2/share/locale/cs/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/de/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/es/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/fr/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/it/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/ja/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/ko/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/pl/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/pt_BR/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/ro/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/ru/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/sv/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/tr/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/zh_CN/LC_MESSAGES/initdb-9.2.mo
/usr/pgsql-9.2/share/locale/zh_TW/LC_MESSAGES/initdb-9.2.mo
1

You're missing the actual postgresql server installation. The package is called "postgresql92-server". The instructions indeed are missing this information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.