Here is my problem: First of all you have to know that I have ArcMap 10.1 SP1. My features are stored in Oracle 11g database in SDO_GEOMETRY format.

I have imported a layer of accidents location in ArcMap. So when I try to select all features included in a polygon (using the Select by Polygon), then too many features are selected. I mean some feature outside my polygon are part of selected feature.

So I draw a triangle on my map and I expect that all features included into the triangle will be selected. The result I obtain is all features included in the rectangle envelope of the triangle that are selected, which is obvious wrong.

Is someone can help me on this one?

You have to know that I was in SDE_GEOMETRY before and I wasn't had the problem when I tried to select by polygon.

Thank you.

Here is my polygon selection (triangle)

This is the wrong result of the polygon selection

The rectangle envelope that seems to be used by ArcMap

  • Are there multipart features? That could cause that behaviour. – Martin Sep 12 '13 at 7:23
  • Thanks but actually it's not a multipart point layer. – Jean-Francois Legendre Sep 12 '13 at 12:46
  • I would open a new mxd and add the relevant data to it. Then try the selection from there. Since it doesn't seem to be related to your features per se, maybe that could fix it. Exporting everything to a shapefile and try in a new document might also fix things. – Martin Sep 12 '13 at 13:22
  • Thanks Martin, but I did all your suggestions and it works well in that way. But I need to use data coming from my database (SDO). – Jean-Francois Legendre Sep 12 '13 at 13:59
  • Please my problem with ArcGIS 10.3 that I tried many times to select some features (polygons) in order to delete them, but the ArcMap always selecting all the polygons not only what I have selected. So, please what I have to do to let ArcMap only select what I need. Many thanks in advance. – user63353 Dec 11 '15 at 15:35

I have seen this behavior several times previously. Once was a bad coordinate system combination between map and data (map in AGD66 and data in MGA) and the second time was indexing on the SDE database.

Ensure map and data are in the same coordinate system (or at least datum) and if the problem persists try reindexing the database if that option is available to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.