0

I'm using Data Driven Pages to display delivery routes associated with hub points. On the extent tab, the "Best Fit" option is grayed out. What could be the cause of this? I think "Best Fit" is exactly what i'm looking for.

ArcMap 10.2 Desktop Advanced.

3
  • 1
    Perhaps including a screenshot of this would be useful. When I am looking at the options, the selection boxes for "Best Fit" are grayed out until you select the radio button, at which time they become active. Is this what you are running into, or something else? Sep 12, 2013 at 15:33
  • Where is this "radio" button located
    – Maksim
    Sep 12, 2013 at 15:35
  • 1
    Let's go back to basics then. Have you tried starting from a blank session of ArcGIS and first adding your index layer, then defining the data driven pages properties? Upon trying this, is the option grayed out? Sep 12, 2013 at 16:15

3 Answers 3

3

I was using a points feature class instead of lines, problem solved. Thanks!

4
  • Please don't add "thank you" as an answer. Instead, vote up the answers that you find helpful.
    – Curlew
    Sep 12, 2013 at 18:49
  • none were helpful, i figured it out, thanks though!
    – Maksim
    Sep 12, 2013 at 18:59
  • @Maksim, since you figured out the answer yourself, please mark your response as the "answer" by hitting the checkmark next to it. While you are at it, please accept answers from your other questions, too. Thanks! Sep 12, 2013 at 19:38
  • I tried that, cant accept my own answer for 2 days. The other questions remain unanswered.
    – Maksim
    Sep 12, 2013 at 19:40
2

Maksim,

It may be that you haven't actually selected the "Best Fit" option, which would then enable all of the grayed out boxes within it.

Try selecting the radio button, next to the words, and see how it changes, as in the before and after pictures below: Prior to Selecting Best Fit: Select Best Fit Option

After Selecting Best Fit: Best Fit Option Selected

As you can see, the parameters within this option are now active for you to modify as necessary.

Hope this helps.

2
  • The option to select "Best Fit" in itself is grayed out, the button. I am only able to click on the other options.
    – Maksim
    Sep 12, 2013 at 15:45
  • Let's go back to basics then. Have you tried starting from a blank session of ArcGIS and first adding your index layer, then defining the data driven pages properties? Upon trying this, is the option grayed out? Sep 12, 2013 at 15:55
0

This is an old post, but has an answer that wasn't addressed. The source geometry of the user's data driven pages is most likely a point feature class/shapefile. You cannot do Best Fit scale options on point-based features (only lines and polygons), which is why the "Best Fit" option is entirely grayed out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.