2

I have an issue with arcmap. In the layout view and dataview it shows all buildings normal (it's a bit blurry, but it's only for a study not for presentation), but when I export it, all gaps between the buildings get filled. I don't know what the error could be and first thought it would be in some export setting, but it isn't. I made an EMF and inserted the picture in Arcmap and the EMF was filled in too. Then I have been trying to fix or find an answer for 3 hours now, while my Arcmap kept freezing too, but still to no avail. If someone could help me fix this, I would be very grateful :)

Probably there is an easy fix to the problem.

ARCMAP filling full layer

Some more background information: All files are shapefiles (vector) When I export just the layer with the building information all works fine.

2

I suspect your problem is similar to what I encountered here: Filled Polygons on the Edge of a Map - ArcMap 10.1

Try running the "Repair Geometry" tool on your polygon layers, especially the layer that is not the buildigs (2e Daaise buurt).

2
  • Thx for the help! When I tried running the repair geometry tool, I got the Unexpected Error 999998 and I'm told to contact the technical support for assistance. So it might be a bug? – Davma Sep 17 '13 at 19:19
  • 1
    The error showing up seems to further indicate that there is a problem with your shapefile. Assuming that it's a shapefile and not a feature class. You could try exporting it to a new copy and trying to run the tool on that. Also, you could start an editing session and look for any weirdness in the vertices of the polygons. If it's a feature class I'd start by compacting/repairing the database. Another thing to try is to turn off background processing, sometimes taking things out of the background gets the tool to run, especially with unspecified errors like this one. – Kevin Sep 17 '13 at 20:20
1

Try instead of exporting the PDF, the print to PDF option. Also I see you got two layers on the legend, by any change does one of them have a transparency setting? Try removing the transparency and just showing the outline to see if it solves the filling up of gaps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.