2

I'm trying to connect ArcGIS Desktop 10.1 to PostGreSQL/PostGIS tables. I have PostGreSQL 9.2/PostGIS 2.0, which was installed with the latest OpenGeo suite. Unfortunately ArcGIS direct connections to PostGres are only supported by ESRI for version 9.1.3. Would it be possible to downgrade my version of PostGres 9.2 to 9.1.3 while maintaining the other up-to-date components of the OpenGeo Suite (i.e. geoserver, geowebcache, etc.)?

0

There is no need to do this. You can download the drivers and successfully access a PostgreSQL 9.2 database from ArcGIS 10.1

Please see the following link: ArcGIS 10.1: Setting up a connection to PostgreSQL

In order to connect ArcGIS Desktop 10.1, you will need to use the pg_client_windows86 set of drivers. These are the 32 bit drivers. Place the files from this set into the bin directory of your ArcGIS Desktop installation.

The same drivers may be used if you have ArcReader and wish to have a direct database connection used in a .pmf configuration file.

Once you have done this, you will be able to create a connection to the database like the one seen here: Postgresql Database Connection

You will know the connection is working in two ways:

  1. There will be no error messages
  2. The list of available databases on that server will show up in the pulldown at the bottom

As proof, here is a screenshot of the database version information from pgAdmin III: pgAdmin database properties

  • This worked! Thanks so much! Now the only problem is that I can connect to PostGres/PostGIS, and ArcMap will display the spatial features, but there are no records. Using Identify and trying to open and view the attribute table result in fields, but no records... – tinyplanet00 Sep 21 '13 at 10:01
  • Glad this worked. There are a couple things that might be leading to that behavior. They have to do with creating a query layer, and the needs for a unique ID field existing. What I would ask you to do, is put up a new question. That way, a discussion on a new topic that others might be interested in, won't get lost in these comments, and other people can weigh in as well. – Get Spatial Sep 21 '13 at 10:16
  • Great idea. I was thinking of doing that, as I was worried this secondary issue would get buried in comments. – tinyplanet00 Sep 23 '13 at 22:18
1

To answer the downgrade question it really depends on what OS you installed on. If on ubuntu it is possible to install multiple versions of postgresql in parallel without the need to downgrade. So you could install postgresql-9.1 from the postgresql repositories and be able to run that without affecting the 9.2 version that was installed as part of opengeo suite.

You will have to transfer any data over manually and change configuration to avoid things like port conflicts, etc...

  • Thanks for the response. I currently have PostGres and PostGIS installed as part of OpenGeo on Ubuntu Server 10.04, so I will consider this as an option. – tinyplanet00 Sep 18 '13 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.