1

My maps georeference just fine in QGIS and I save them to jpg with jpgw. The jpg image loads but the jpgw file does not. I keep getting the error message "this is an unsupported file", or words to that effect. I have tried bmp and bmpw, tif and tifw and tiff and tiffw with the exact same result.

I got the same result with Global Mapper but surprisingly, OK Maps loaded both the image file and the world file perfectly. My GPS receiver tracks accurately with OK maps also.

Please help any way you can. I really enjoy using QGIS.

Thanks, Jim

  • 1
    Try renaming it .wld, but otherwise can you post your .jpgw file and provide some details about the .jpg file, and more detail about what you do and the problem? "words to that effect" is not very useful. – mdsumner Sep 21 '13 at 6:09
1

You don't have to load the jpgw file.

Just select the .jpg file, and QGIS will use the .jpgw if it is present in the same directory.

CRS information is not provided in the world file, so you have to select that manually.

  • Hello Andre, Thank you very much for your very quick response. The reason I thought the world file was not loading was because when I connect my GPS, the GPS marker appears on the blank map canvas and the actual map disappears. When I zoom to the layer extent the map reappears but overlays the GPS marker. Then it quickly disappears again. I assumed the georeference data was not there for the GPS. By the way, the map disappears and returns exactly the same way in Global Mapper. The map itself indicates EPSG 4326 in the lower right hand corner. Please help. Thanks, Jim – Jim Sep 21 '13 at 6:58
  • 1
    Have you enabled On-the-fly-Reprojection? Maybe something went wrong with your georeferencing. Note that laver and project may have different CRS. What do you get from rightclick on the layer -> Set CRS for layer? And what is given as Layer extent under Properties, Metadata tab? Saving the georefrenced picture as tif would include worldfile information and CRS, thats why I prefer that format. – AndreJ Sep 21 '13 at 15:07
  • Andre, thanks for responding. Sorry I did not get back to you earlier-got pulled away. – Jim Sep 21 '13 at 22:36
  • Andre, thanks for responding. Sorry I did not get back to you earlier-got pulled away. Yes, On the fly reprojection is enabled. CRS for layer says EPSG 32618. The lower right hand corner of the map also says EPSG 32618. Layer extent under Properties, Metadata tab is-77.2429799392014189,38.7575770511575115 : -76.9341074877932414,38.8583806127049485 (hope that means something to you). I used tif to georeference and got the corresponding tifw file. I checked the map using OK Maps and it loads and tracks my GPS perfectly. (Not sure how to make paragraphs-sorry for the mess.) Thanks, Jim – Jim Sep 21 '13 at 22:56
  • The metadata extent is in degrees, but the layer CRS 32618 UTM 18N is in metres. Rightclick -> Set CRS for layer to EPSG:4326 should help. But you better do the georeferencing correctly from the start. – AndreJ Sep 22 '13 at 5:48
0

Andre is right. However, to compound the issue not all systems will recognise a file with the extension '.jpgw'. I use some software which refuses to acknowledge world files with long extensions. I believe that QGIS does, though it will not like it if you try to load the world file by itself.

In general I find it safer to go with the short conventional names. In this convention, the second letter of the extension is dropped and then the 'w' appended to the end: jpw, bpw, tfw, pgw and so on. I suspect this could be the problem with your GPS. When I find world files are not being recognised, I automatically check to see what naming convention is being used for the extension and if it has a long extension, I change it to the short form, a move which usually solves the problem (if the world file is valid).

  • Thanks very much for your answer. I tried renaming the file jpw and the GPS still bounced the map away. I tried jgw, which is what OK Maps successfully uses, and still no luck. Thanks everyone for your excellent answers. I live near Washington, DC, USA and it is almost 4AM here and I have to get some sleep. I will eagerly pick up on this tomorrow morning. Thanks, Jim – Jim Sep 21 '13 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.