I recently installed QGIS 2. I used the advanced OSGeo4W installer that I downloaded from the QGIS download page. GRASS is included in the stack. When I attempt to open GRASS, I receive the following error message:

The procedure entry point libintl_setlocale could not be located in the dynamic link library libintl-8.dll.

I checked the WinGRASS errors page on the GRASS wiki and did not discover any precedent for this problem either there or by a Google search.

My operating system is Windows Vista. I've installed all recommended packages as outlined on the GRASS wiki.

Has anyone else encountered this problem? And how might I go about resolving it?

Here's a running list of potential solutions that have not corrected the problem. I'll update as I get the time to try them:

  1. Run Microsoft .NET cleanup utility and reinstall .NET 3.5.
  2. Run system file checker from command prompt (>sfc /scannow).
  • I've experienced the same problem, and some plugins for QGIS, such as the GRASS plugin, are not available.
    – Bernie
    Commented Sep 22, 2013 at 17:17
  • You report that you installed QGIS 2 and then encountered the GRASS problems. How is that related?
    – markusN
    Commented Sep 28, 2013 at 8:15
  • @markusN I used the advanced OSGeo4W installer that I downloaded from the QGIS download page. GRASS was included in the stack. Do you think it would be worth it for me to edit this clarification into the main post?
    – Darin
    Commented Sep 28, 2013 at 12:36
  • I have the same problem installing qgis 2 with the file (windows XP): QGIS-OSGeo4W-2.0.1-2-Setup-x86.exe Did you resolve the problem?
    – user22510
    Commented Oct 1, 2013 at 14:19
  • @workweek: yes, please... just to minimize confusion
    – markusN
    Commented Oct 1, 2013 at 15:57

4 Answers 4


The installer might have been fixed, see http://trac.osgeo.org/grass/ticket/2096#comment:4

  • It works now! Thank you for the info. To the admins: this question has been satisfactorily answered.
    – Darin
    Commented Oct 12, 2013 at 2:22
  • Haha. New to this. Done!
    – Darin
    Commented Oct 14, 2013 at 21:49

I have the same problem--on Windows 7. Looking back, this is apparently an old problem. The dll is in ROOT\OSGeo4W\bin. However, I have no idea of what to do. I installed mine with a binary. The earlier version of this issue (few years ago) was assumed solved in the OSGeo forum--but I'm not sure how...

  • Yeah, I encountered other threads discussing a similar problem with other DLLs, but not libintl-8.dll. I opened libintl-8.dll using 7-zip, but was unsure what I was looking at. I encountered a similar problem in this thread. I'll attempt some of the proposed solutions and report back.
    – Darin
    Commented Sep 22, 2013 at 16:44

The 32bit installer I downloaded yesterday does contain the libintl-8.dll file, installed in the QGIS Dufour\bin directory. But we non-English users still can not start GRASS, there are error messages in local language saying something like: "Entry point of procedure libintl_setlocale in dynamically linked library libintl-8.dll was not found". There is ticket for this problem and it should be already fixed, although it may take time until the fix appears in the installer talked about here.


close QGIS

Try to download libintl-8.dll from


then uncompress it and paste it into C:\Program Files\QGIS Dufour\bin or whatever path you have for libintl-8.dll.

run QGIS


Not the answer you're looking for? Browse other questions tagged or ask your own question.