1

While using ArcGIS 10.1, I had an issue importing annotation feature classes into a file geodatabase. Using Import Feature Class (Single) or Import Feature Class (Multiple) on an annotation feature class resulted in null values for the font size, angle, text etc. in the annotation feature class, but worked fine when used on any other feature class types.

The Conversion tool Feature Class to Feature Class when used alone or as part of a python script also resulted in null values, but when used with the Iterate Feature Classes iterator in ModelBuilder, the annotation feature classes retained their values for size, angle, text etc., but the annotation was changed into a polyline feature class and appeared as a line on the map where the text should have been.

I have tried to export/import annotations from file geodatabases, personal geodatabases and coverages and always got the same result – null values, or if used with ModelBuilder, a polyline instead of an annotation.

The only solution that seemed to work is right clicking on the annotation, copying and then pasting it into the other geodatabase.

Last week the computer was upgraded to ArcGIS Desktop 10.2 and the Import Feature Class (Single) / Feature Class to Feature Class tool works perfectly when used as a standalone tool, but when used with the Iterate Feature Classes iterator null values are returned.

Is there a solution other than using the copy/paste method?

2
  • Is the spatial reference for the annotation feature class and the file geodatabase the same?
    – Arash
    Commented Sep 25, 2013 at 2:37
  • The spatial reference is the same. The data is basically being transferred from one geodatabase to another.
    – Adam Thom
    Commented Sep 26, 2013 at 15:43

1 Answer 1

-1

this is the best solution copy and paste the annotation feature classe

1
  • 2
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jan 3, 2023 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.