2

Trying to use QGIS 2.0 on Mint 15 (based on Ubuntu 13)

I installed, uninstalled and re-installed QGIS from various repositories (ubuntugis-unstable, then qgis.org/debian raring - not clear for me which one I should use). I don't seem to have any python support. Any help appreciated!

If I try

apt-get install python-qgis

I get the message that

the packages libgdal1 libqgis2.0.1 qgis qgis-providers 
are going to be uninstalled    

Bump: Still no solution. I uninstalled QGIS and apt-get autoremove, kept only ppa:ubuntugis/ubuntugis-unstable. Now when I try

sudo apt-get install qgis python-qgis qgis-plugin-grass

the error message is

Les paquets suivants contiennent des dépendances non satisfaites :
 python-qgis : Dépend: python-qgis-common (= 2.0.1-2+raring1) mais ne sera pas installé
 qgis-plugin-grass : Dépend: grass642
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Can someone help?

  • 1
  • Thanks a lot for your answer. But which one of the two should I use? And should I first disable the repository I have used before (qgis.org/debian raring main)? Should I uninstall QGIS and then re-install it? – Alice Sep 26 '13 at 14:05
  • 1
    I had a similar problem 2 years ago with QGIS 1.7, which I solved by downgrading my PyQT4 library. The library had been updated and became incompatible with python-qgis. Link to my original error message and solution, in case that helps: northwestspatial.com/wp/?p=302 – L_Holcombe Sep 26 '13 at 14:09
  • @Alice check the dates on both 24th September 2013. Would try the qgis.org first. – Mapperz Sep 26 '13 at 14:15
  • Mapperz thank you but I don't understand much. Should I add deb qgis.org/debian/dists/raring/main in the file source.list? – Alice Sep 26 '13 at 14:40
4

Ok this is what finally worked though I'm not sure why (using aptitude instead of apt-get? It seems that aptitude manages better the dependencies).

First I cleaned a little (not sure it's useful)

sudo apt-get purge qgis python-qgis

sudo apt-get autoremove

and suppressed the qgis.org/debian repository from sources.list

Then

sudo aptitude install python-software-properties

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

sudo aptitude update

sudo aptitude install qgis python-qgis

QGIS works now WITH vector tools and python support. Thanks to http://blog.m0le.net/2013/10/01/installer-qgis-2-0-sur-mint/

|improve this answer|||||
  • Now in 2014 you should add stable ubuntu repo instead of unstable, so sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable should be sudo add-apt-repository ppa:ubuntugis/ppa – Krystian Apr 9 '14 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.