2

I have a problem with r.surf.contour. I create a DTM with v.to.rast.attribute and then use the r.surf.contour and it works fine in QGIS 1.9 but with QGIS 2.0 doesn't work.

I have a contour shapefile with elevation values. I use the v.to.rast.attr to rasterize the contour, but some pixels have null values, so I try to use the r.surf.contour to obtain a surface but in the end I've got an error. This is an excerpt: GRASS_INFO_ERROR(3016,1): Unable to load GDAL library GRASS_INFO_END(3016,1) C:\PROGRA~1\QGISDU~1\bin>g.region rast=output91bad3077faa4aa784bcedb42867ff89 And then GRASS_INFO_ERROR(1012,1): Raster map not found.

I think the problem is in raster from grass. Because I try to create a slope map with r.slope.aspect and it give me the same error. Please could you help me? My windows is Windows vista.

4
  • 2
    Could you please tell us how it fails to work? – whuber Sep 30 '13 at 14:08
  • You after that you could raise a bug here: hub.qgis.org/projects/sextante/issues – Curlew Sep 30 '13 at 14:10
  • Thank you for the quick response. I have a contour shapefile with elevation values. I use the v.to.rast.attr to rasterize the contour, but some pixels have null values, so I try to use the r.surf.contour to obtain a surface but in the end I've got an error. This is an excerpt: GRASS_INFO_ERROR(3016,1): Unable to load GDAL library GRASS_INFO_END(3016,1) C:\PROGRA~1\QGISDU~1\bin>g.region rast=output91bad3077faa4aa784bcedb42867ff89 And then GRASS_INFO_ERROR(1012,1): Raster map not found. – Bárbara Duarte Sep 30 '13 at 14:18
  • I think the problem is in raster from grass. Because I try to create a slope map with r.slope.aspect and it give me the same error. Please could you help me? My windows is Windows vista. – Bárbara Duarte Sep 30 '13 at 14:41
2

If you use Sextante and if you have errors you must first look the sextante log file in Yourpath/.qgis2/processing/processing_qgis.log. Generally, error messages are explained more clearly.

In your case, the error:

Unable to load GDAL library GRASS_INFO_END(...

means "It was not possible to load GDAL library" and as a consequence GRASS cannot load the raster file -> GRASS_INFO_ERROR(1012,1): Raster map not found.

So,

  1. it is a problem of configuration in sextante/processing Settings (fix the GDAL path)
  2. it is the result of a known bug with the Windows 2.0 standalone installer : QGIS 2.0 Win standalone busted -> you have to wait for a new version of the Windows 2.0 standalone installer (with corrections) or use the 1.9 version.

and look in the QGIS devoloper list or the QGIS user list

3
  • Thanks for the help. But where do I fix the GDAL path? In processing Options and configuration, I just have a check box for activate. Nothing else. – Bárbara Duarte Sep 30 '13 at 16:50
  • in GDALTools parameters, Raster menu – gene Sep 30 '13 at 17:12
  • I have a lot of paths. Which one I have to fix: executables, python modules or help path? I have another two paths: data path and driver path but they are locked. All these paths are indefined. How I fix that? – Bárbara Duarte Oct 1 '13 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.