8

After upgrade of qgis 1.8 to qgis 2.0 I couldn't find the choice "Get more" in Plugin Manager and I can't install plugins.

enter image description here enter image description here

  • Can you provide a screenshot of what the plugin installer looks like? – underdark Sep 30 '13 at 18:45
15

Please make sure that you have the same version for qgis and python-qgis.

dpkg -l | grep qgis

It you update qgis from the ubuntugis-nightly repository, for example, you also need to update python-qgis and python-qgis-common. There is no explicit depedency, so you might end up with different versions for qgis and python-qgis.

In my Ubuntu 12.04.3, I was not able to get more plugins, because I had:

ii qgis 2.1.0+git20131011+4cb37b1~precise-ubuntugis1 
ii qgis-common 2.1.0+git20131011+4cb37b1~precise-ubuntugis1
ii libqgis2.1.0 2.1.0+git20131011+4cb37b1~precise-ubuntugis1             
but also:
ii python-qgis 2.0.1-2+precise1
ii python-qgis-common 2.0.1-2+precise1

Doing

sudo apt-get install python-qgis python-qgis-common

solve my problem and might solve yours.

1

I found the problem, it was a conflict betwween a package and qgis-Python wich I couldn't install qgis-Python. But unfortunatelly I don't remember the name of file. I uninstall this file and then I install qgis-python. It was something with sql in the body of names programm. The name of this programm you can find in error message when you try to install qgis-python.

1

I solved my problem.

As suggested above I looked at the different versions using this command in the terminal.

dpkg -l | grep qgis

Then instead of using "apt-get" I used "aptitude". The following command upgraded all the qgis version to the latest.

sudo aptitude upgrade

This worked for me, now I have access to all my plugins again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.