6

I have been trying to get this working for a few weeks now. I am trying to install QGIS Dufor (2.0.1) and Saga GIS from the Unstable branch of the UbuntuGIS PPA. When I attempt to do this I get the following error

The following packages have unmet dependencies:
 saga : Depends: libsaga (= 2.0.8+dfsg-4~raring) but 2.1.0-0~raring2 is to be installed
E: Unable to correct problems, you have held broken packages.

It appears that the dependencies have not been updated. When I try to install saga from the Johanvdw/saga-gis ppa i am told that two dependencies are too old and required by QGIS. The only way I can get both programs installed at the same time is to install the QGIS nightly build. When I do things this way Sextante can not seem to locate the saga routines. With the changes in sextante now that it has been added to trunk, there is no longer a field to specify the directory that SAGA resides in. I have a similar topic open HERE. I am out of ideas at this point.

6

So I tried some more things and came up with a solution. I will go over what I did step by step and hopefully this will work for others.

First thing I did was uninstall qgis as completly as I know how

sudo apt-get autoremove qgis
sudo apt-get autoclean

Then I removed the Ubuntugis-unstable PPA

sudo apt-add-repository remove PPA:ubuntugis/ubuntugis-unstable

I went to the qgis website and added the qgis Dufor deb and deb-src to my software & updates application

deb http://qgis.org/debian raring main

deb-src http://qgis.org/debian raring main

Next I added the keyserver info by typeing the following commands into the terminal

gpg --keyserver keyserver.ubuntu.com --recv 47765B75
gpg --export --armor 47765B75 | sudo apt-key add -

Once I had everything added to my list of repositories I used the update command

sudo apt-get update

From here I ran 4 commands to install qgis and saga. I had to do each command separately, whenever I tried to do them all in one go I would get error messages

sudo apt-get install python-qgis-common
sudo apt-get install python-qgis
sudo apt-get install qgis
sudo apt-get install saga

Once all of this had been completed I was able to run qgis and saga at the same time and sextante was able to find and execute saga modules.

1

I've updated the ubuntugis ppa - it should now be possible to in stall both qgis and saga (last version) from the ubuntugis ppa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.