1

Exactly the same as this problem from way back, only I've had this from 1.8.0 to present (2.1.0 master).

Yay, symbols: enter image description here

Boo: no symbols, cue MS Paint: enter image description here

Anyone know why this might be or have the same problem?

Happens on Win7 & Ubuntu (& Xubuntu) 13.04.


This issue raised on hug.qis.org (and can be subscribed to) here.

  • Have you just tried in 2.0? – Nathan W Oct 2 '13 at 23:21
  • Hi Nathan. @ctpult mentioned (below) about trying 2.0 also; I've not tried 2.0 but can confirm it works in 1.8. I don't have a 2.0 available... is that a stable beta which should be an option if I have master installed? Or is it a separate install? Thanks! – dez93_2000 Oct 3 '13 at 11:03
  • Get 2.0 from here qgis.org/en/site/forusers/download.html – Nathan W Oct 3 '13 at 11:19
  • Thanks Nathan, sorry that that was an obvious question; I wasn't sure if it should also install the big beta releases by default. Given this, I'll mark this as solved, with the caveat that it's broken in 2.1.0 master - should I report this as a bug to hub.qgis.org? – dez93_2000 Oct 3 '13 at 11:53
  • Already exists, should have checked, sorry. Link added as edit to main question. – dez93_2000 Oct 3 '13 at 12:01
0

I had the same problem with vector data on version 2.1.0 master but got it solved by opening the project with 2.0 version.

  • can confirm that it works fine in 1.8.0 also - good to know at least there's the fallback if required. – dez93_2000 Oct 2 '13 at 14:11
0

I have seen the same thing with rasters. I can't tell you why it happens but the solution is easy. Simply remove the layer in question from the legend and then re-add it. Sometimes the 'Update item' button does the trick but not always.

Another quirk I've found is that sometimes it seems unresponsive if you try to change the text for the labels or the title. The simplest way to work around that glitch is to change the layer title in the first tab of the layer properties (and it's probably best to change the label text in the style tab of the layer properties while you're at it). Then do the remove-and-add-again trick in the legend and all will be well.

This problem seems to be isolated to rasters and in particular when the raster is changed or added and a map is already open

  • thanks for the tip. Sadly mine's vector and this trick doesn't work. Boo! – dez93_2000 Oct 2 '13 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.