0

I am trying to figure out how to get a WFS service working with ArcMap. I have Geoserver up and running and I am able to add a WFS layer in QGIS but not ArcMap. I have tried to use the Data Interoperability Tool in ArcMap to connect to my server but there are no layers displayed in select Feature Types dialog. I am able to connect to a WFS server so I'm assuming that I have overlooked some detail about how ArcMap wants Geoserver to be configured.

1

I'm answering my own question in case someone else runs into this problem. It turns out this was related to a bug with the 10.1 release of ArcMap. It was addressed in the 10.2 build.

  • Are you able to provide any details of the bug you believe ArcGIS 10.2 resolved to help you here e.g. did you find an NIM number? – PolyGeo Jan 27 '14 at 20:19
  • Unfortunately the ESRI support person did not give me any information about the specific bug that was causing this problem. She found out about the fix when she tried to log my issue in their system. – dblanchett Jan 28 '14 at 3:31
  • Did you actually see your problem go away when you tried 10.2 instead? It is just that it seems to have cropped up again (gis.stackexchange.com/questions/84426/…) and, if it is the same bug, then my 10.2 test suggests it has not been fixed. – PolyGeo Jan 28 '14 at 3:38
  • It did fix the problem originally, but I have not been working with WFS/Geoserver for the last couple of months. I'll try to look into later on today to see if it's still working. Maybe this problem was reintroduced in the 10.2.1 service pack. – dblanchett Jan 28 '14 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.