1

I was trying to install QGIS on centos 6.3 and follow the instruction here.

However after running yum install qgis qgis-python qgis-grass qgis-mapserver I got below errors:

    ---> Package libvpx.x86_64 0:0.9.0-8.el6_0 will be installed
    ---> Package python-setuptools.noarch 0:0.6.10-3.el6 will be installed
    --> Finished Dependency Resolution
    Error: Package: grass-6.4.2-8.el6.x86_64 (elgis)
               Requires: libgeos-3.3.8.so()(64bit)
               Available: geos-3.3.8-2.el6.x86_64 (elgis)
                   libgeos-3.3.8.so()(64bit)
               Installed: geos-3.4.1-1.el6.x86_64 (@opengeo)
                   Not found
               Available: geos-3.2.2-1.el6.rf.x86_64 (rpmforge)
                   Not found
               Available: geos-3.2.2-2.el6.x86_64 (elgis)
                   Not found
               Available: geos-3.3.0-1.el6.x86_64 (elgis)
                   Not found
               Available: geos-3.3.1-2.el6.x86_64 (elgis)
                   Not found
               Available: geos-3.3.2-1.el6.i686 (epel)
                   Not found
               Available: geos-3.3.6-1_0.el6.x86_64 (elgis)
                   Not found
    Error: Package: grass-libs-6.4.2-8.el6.x86_64 (elgis)
               Requires: libgeos-3.3.8.so()(64bit)
               Available: geos-3.3.8-2.el6.x86_64 (elgis)
                   libgeos-3.3.8.so()(64bit)
               Installed: geos-3.4.1-1.el6.x86_64 (@opengeo)
                   Not found
               Available: geos-3.2.2-1.el6.rf.x86_64 (rpmforge)
                   Not found
               Available: geos-3.2.2-2.el6.x86_64 (elgis)
                   Not found
               Available: geos-3.3.0-1.el6.x86_64 (elgis)
                   Not found
               Available: geos-3.3.1-2.el6.x86_64 (elgis)
                   Not found
               Available: geos-3.3.2-1.el6.i686 (epel)
                   Not found
               Available: geos-3.3.6-1_0.el6.x86_64 (elgis)
                   Not found
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

my yum repolist shows:

    yum repolist
    Loaded plugins: fastestmirror, refresh-packagekit, security
    Loading mirror speeds from cached hostfile
     * epel: ftp.jaist.ac.jp
     * rpmforge: ftp.heanet.ie
    repo id                                                      repo name                                                                                          status
    base                                                         CentOS-6 - Base                                                                                    6,381
    elgis                                                        EL GIS 6 - x86_64                                                                                    198
    epel                                                         Extra Packages for Enterprise Linux 6 - x86_64                                                     9,757
    extras                                                       CentOS-6 - Extras                                                                                     13
    opengeo                                                      opengeo                                                                                               52
    rpmforge                                                     RHEL 6 - RPMforge.net - dag                                                                        4,638
    updates                                                      CentOS-6 - Updates                                                                                 1,326
    repolist: 22,365

How can I proceed to install the QGIS?

I tried the --skip-broken method but QGIS cannot be loaded.

  • Does it work if you try to manually install geos-3.3.8? Perhaps you want to enable the whole elgis repository? – BradHards Oct 4 '13 at 5:17
1

You have installed a newer version of geos (3.4.1 vs 3.3.8) on your system, which is from the opengeo repository. QGIS-Grass requires 3.3.8 to run.

You can downgrade this library to version 3.3.8 from the elgis repo, but that may fail, if other applications requires the newer library. In which case you have to decide if you want to keep the other applications or install QGIS.

yum downgrade geos-3.3.8-2.el6.x86_64

However, you might consider installing QGIS without grass support if you don't need it (but this may fail as well, if there are other dependencies to this version of geos)

yum install qgis qgis-python qgis-mapserver

And last but not least, you could also build your own QGIS version, which is linked again the opengeo version of geos.

  • I tried to do a clean installation with qgis,qgis-python but when I load qgis it shows error loading shared libraries: libhdf5.so.6. I can find the file at /usr/lib64/mpich2/lib/libhdf5.so.6 – Xianlin Oct 4 '13 at 8:24
  • May be related to gdal bugs.archlinux.org/task/25089 – Matthias Kuhn Oct 4 '13 at 10:19
0

I've had excellent luck installing QGIS on CentOS using Conda. Even using EPEL repositories I was always left with a broken QGIS that could at least display spatial data but I couldn't use any of the processing functions. To use Conda to install QGIS issue the following conda command line argument:

conda install -c conda-forge qgis=2.18.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.