2

Since QGIS 2.0.1 the default color ramps and styling symbols seem to disappear for some users. For me, this started with QGIS 2.0.1 and still consists with 2.4. I can neither choose Smybols when styling a line vector layer, nor choose from default color ramps.

I'm looking for a universal solution to tackle this problem. There is already an open bug report, but it seems to be forgotten.

enter image description here

  • Can you add more detail and perhaps a screen shot because this issue is not universal to QGIS 2.0.1 (I have all the default colour ramps). Also can you state your operating system. – MappaGnosis Oct 6 '13 at 17:39
  • Thank you MappaGnosis. I run QGIS on Windows 8. How can I attach a screenshot here? – Andres Aristizabal Oct 6 '13 at 17:57
  • I'm using Windows 7 so I don't know if that's an issue. To add a screenshot there should be a little picture icon above the box when you edit your question. – MappaGnosis Oct 7 '13 at 10:12
  • 1
  • No solution to this problem. I´ve installed the 32 bit version and the problem is still there. Any ideas or workarounds? – Andres Aristizabal Oct 14 '13 at 16:08
1

This is a possible solution (i.e. I don't guarantee it will solve your problem but it's worth trying):

The clue I picked up was in the bug report linked by Gene. It appears to be a bug in the stand-alone installer. I always use osgeo4w and don't have the problem - so maybe this is a possible solution.

If you don't want a ton of other software installed (much of it also briliant!) then go to Advanced settings, expand the Desktop listing and select QGIS from there. With the 64bit version you may have to also manually select GRASS and SAGA if you want them, but with the osgeo4w installer, you can always go back and add anything that is missing if you discover you forgot something. Also, it should detect all the required dependencies, so accept those.

To be on the safe side, if it was me, I would completely uninstall all previous versions of QGIS before attempting this in case something is getting left behind during a simple update. Uninstalling should also involve removing the various directories (the uninstaller doesn't seem to do this). That said, I can't guarantee this will work for you and it's just a suggestion of something to try.

  • It worked for me! I uninstalled all GIS versions and deleted also the remaining files in my windows user directory. After installing QGIS with osgeo4W, the colour ramps and everything appeared properly. Thanks! – Gideon Jul 29 '14 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.