5

I have a folder with .sdw and .sid files I want to server using geoserver. I've followed the instructions here which basically means to install GDAL extensions and binaries on the geoserver machine.

When I go back to stores after reseting the service I still don't see MrSID store. any thoughts? running on windows server 2008.

Here are the steps I did to install it on server 2008 x64 on geoserver 2.4.0:

  1. Downloaded GDAL extention from here and put it in Geoserver/web-inf/lib
  2. Downloaded Imageio-Ext jars from here and put them in Geoserver/web-inf/lib
  3. Downloaded gdal-data.zip from here and put it in program files\gdal-data
  4. Added GDAL_DATA with path to the folder in no. 3 in system variables
  5. Downloaded gdal-1.9.2-MSVC2008-x64.zip and put the content in program files\gdal-1.9.2
  6. Added no.5 folder to system variable PATH
  7. Installed gdal-19-1500-x64-mrsid.msi and put the dll in PATH location (system32)
  8. checked that gdalinfo.exe --format MrSid works (and it did)
  9. Since I run geoserver as service , I moved the DLLs from 5 (native) to the wrapper\lib folder.
  10. Restarted Geoserver service ... Don't see MrSID or any change in stores.

What did I miss ?

There is a section saying :

Adding support for ECW and MrSID on Windows If you are on Windows and you want to add support for ECW and MrSID there is an extra step to perform. In the Windows packaging ECW and MrSID are built as plugins hence they are not loaded by default but we need to place their DLLs in a location that is pointed by the GDAL_DRIVER_PATH environmental variable. GDAL uses internally this env variable to look up additional drivers (notice that there are a few default places where GDAL will look anyway). For additional information, please, check this link.

Did I miss it ? If so , what needs to be done here ? which files I need to put where ?

  • Did you manage to resolve this issue? The response is marked as solved, but I see no so solution. I am in the exact same situation only I'm on geoserver 2.9. When I start tomcat I get an error in the output window saying that it can't load the mrsid dll because of an unkown procedure; same for ecw. – Ultimate Gobblement Oct 13 '16 at 15:17
1

Have you set the environment variable GDAL_DRIVER_PATH? Not having that has tripped me up. Mine looks like C:\Program Files\GDAL\gdalplugins. When I ran the GDAL MrSID Extension setup that is where those files ended up.

  • Yes I did. the gdalinfo.exe --formats runs.. but I dont see new stores in geoserver – Alophind Oct 7 '13 at 16:48
  • I do not have any other suggestions. I know it works on windows server 2008, and I had to read the setup instructions very carefully a couple of times to get the Mr Sid store. – Ralph Dell Oct 7 '13 at 17:18
  • I'll edit the post with all steps I did , Will be nice if you could follow and say If I missed something. – Alophind Oct 7 '13 at 17:49
  • I've edited my question , I'll be more than happy if you could check my steps. – Alophind Oct 7 '13 at 18:28
  • Which MSVC GDAL did you download ? 2005 , 2008 , 2010 ? – Alophind Nov 9 '13 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.