3

I try to import a KML-Placemark file with QGIS (--> Add Vectorlayer, UTF-8). When i import the File with my Mac (OS 10.6) i don´t have any problems viewing all the attributes stored in the KML-File (they are stored in the Tag "ExtendedData")

enter image description here

but when i import the same KML-File in the same QGis Version on a Windows 8 OS i only see the attributes "Name" and "Description" (The points are shown correctly)

enter image description here

this is referring to my question here: KML in QGis with additional Data i thought the problem is solved but it is only to 50 % :)

here is my updated kml-file:

<?xml version="1.0" encoding="UTF-8"?><kml xmlns="http://www.opengis.net/kml/2.2">
<Document>
<Placemark id="PM1">
<TimeStamp>
        <when>2007-01-14T21:05:02Z</when>
      </TimeStamp>
<name>Data1</name>
<description>AA</description>
<ExtendedData>
<Data name="Orientierung">
<displayName>Orientierung</displayName>
<value>1</value></Data>
<Data name="Brennweite">
<displayName>Brennweite</displayName>
<value>279/100</value>
</Data>
<Data name="Datum">
<displayName>Datum</displayName>
<value>2013:04:04 13:20:49</value>
</Data>
<Data name="Pfad">
<displayName>Pfad</displayName>
<value>file:///C:\Temp\20130404_132050.JPG</value>
</Data>
<Data name="Kamera">
<displayName>Kamera</displayName>
<value>GT-P3110</value></Data>
</ExtendedData>
<Point>
<coordinates>15.448561,47.11721,0</coordinates>
</Point>
</Placemark>

<Placemark id="PM2">
<TimeStamp>
        <when>2007-01-14T21:05:02Z</when>
      </TimeStamp>
<name>Data2</name>
<description>AA</description>
<ExtendedData>
<Data name="Orientierung">
<value>5</value></Data>
<Data name="Brennweite">
<value>400/400</value>
</Data>
<Data name="Datum">
<value>2013:04:04 13:20:50</value>
</Data>
<Data name="Pfad">
<value>file:///C:\Temp\HUGO.JPG</value>
</Data>
<Data name="Kamera">
<value>GT-P3110</value></Data>
</ExtendedData>
<Point>
<coordinates>16.458561,48.15721,0</coordinates>
</Point>
</Placemark>
</Document>

</kml>

does anyone know why this problem is appearing?? hope you can help me!
thanks michik

4

The QGIS version of Mac OS X (Dufour - KyngChaos) uses GDAL 1.10.1

enter image description here

While the standalone Windows version use GDAL 1.9.X (32 bits) or GDAL 1.10.0 (64 bits)

enter image description here and

It seems that the Windows 2.0 standalone installer is packaged wrong. It seems to include outdated and removed plugins. plugin_installer, osm_export, mapserver_export. None of these work with 2.0 and have been removed from the source not sure why they are showing up in in the final build, or even how. Nathan Woodrow in QGIS 2.0 Win standalone busted

  • Thank you gene! Do you know if its possible to change the GDAL Version within the Windows standalone to 1.10.1 manually? Maybe replace the .dll or something like this? – MichiK83 Oct 8 '13 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.