2

While trying to follow the tutorial of Opengeo for creating a new application, I am getting stuck on one of the first steps: namely the addition of a new server dialog. (http://suite.opengeo.org/docs/apps/clientsdkintro/viewer/addnewserver.html)

I added the following lines in my app.js and restarted my server application. Unfortunately I cannot get the "Add a New Server ..." line as described in the tutorial when adding new layers.

* @require overrides/override-ext-ajax.js ... proxy="proxy/?url="

The full content of my app.js is available at https://gist.github.com/anonymous/6899291

Note that I am starting my application using the following command on a Linux machine where Opengeo was installed : suite-sdk debug -g http://localhost:8080/geoserver myapp

Thanks

1

Ah this one is an easy one. You have added the proxy setting to the wrong part of the the gxp.viewer configuration.

Where you have:

var app = new gxp.Viewer({
portalConfig: {
layout: "border",
region: "center",
proxy: "proxy/?url=",

Instead put:

var app = new gxp.Viewer({
proxy: "proxy/?url=",
portalConfig: {
layout: "border",
region: "center",

At the moment you are adding the setting to gxp.Viewer.portalConfig not gxp.Viewer

I tested this quickly and it worked on my sytem with te latest version of the OpenGEO SDK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.