I have an MXD that I put a lot of time and work into for cartographic purposes which unexpectedly stopped working after a reboot, and I really, really don't want to have to recreate it again from scratch if I don't have to. Chain of events and error message below...

All was fine with this MXD up until yesterday. I had started setting up the layers to display the way I want, setting up the map layout, legend, symbol levels, etc. The issue started after I added a few shapefiles from a server. The specific files and server in question, I use on a fairly regular basis and have never had issues with. The map started drawing, saving, editing, panning, etc all very slowly. I removed those recently added shapefiles, saved my work, closed everything and rebooted. Now I get this error every time I try to open the MXD:

ArcMap Error

I tried a couple different options I found by googling, including resetting the application profile, to no avail. I ran the MXD repair tool, and it found nothing corrupt, but I used it to copy my settings and layers to a new MXD anyway, which also returns the same error. Other map documents open and work just fine. I'm at a loss.

closed as off-topic by PolyGeo Aug 18 '16 at 9:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • has your language/Keyboard changed from English(United States)? can your retrieve from a backup? – Mapperz Oct 8 '13 at 16:58
  • 2
    I'm sorry but I just had to laugh when I saw "Visual Fortran". Have you sent this in to ESRI support yet? I am sure they will love debugging that one. – blah238 Oct 8 '13 at 17:04
  • 2
    recommend: windows.microsoft.com/en-ca/windows7/… – Mapperz Oct 8 '13 at 17:08
  • 4
    As a last ditched attempt to recover the symbology that you spent time and effort creating you could try writing some python using arcpy to save out layer files (symbology\labelling not the data)? Search help for "Layer (arcpy.mapping)" for information on this. – Hornbydd Oct 8 '13 at 19:49
  • 2
    Wild suggestion: try to 'repair' the ArcGIS installation. (hey, at least I'm not suggesting to re-install) This is based on an Esri forum post where the dforrt.dll needed to be replaced. – mkennedy Oct 8 '13 at 21:12

You could also try the MXD Doctor. He can sometimes fix things, and he's very inexpensive.
I wasn't sure if this was the same thing as the MXD repair tool you mentioned: MXD Doctor

  • Yeah, that is what I was referring to. – brock Dec 9 '13 at 14:49

Have you deleted your Normal.mxt from C:\Users\\AppData\Roaming\ESRI\Desktop10.2\ArcMap\Templates

"resetting your application profile" might have already done this but it is regenerated whenever ArcMap is launched.

  • Yes, I already did that. That's what I meant by resetting my application profile. – brock Oct 9 '13 at 16:31

Maybe rename that Roaming ESRI folder to OldESRI (if you haven't done this already) and the whole folder will be regenerated, generally this is what is called a profile reset.

Not the answer you're looking for? Browse other questions tagged or ask your own question.