1

I am new in GIS. I use QGIS 2.0.1 with OpenLayers plugin downloaded from official repository. When I click to Add OpenStreetMap layer the map is not showing and load process is never ending. What is the problem and how can I solve it ?

3
  • Did you install OpenLayers plugin using the plugin installer? Is your computer behind a proxy?
    – underdark
    Commented Oct 10, 2013 at 18:18
  • I have a problem the plugin Openlayers in QGIS 2.0 because when I try yo add a layer for example Google Physical Layer it generates a windows with the next message: Ha ocurrido un error mientras se ejecutaba el código de Python: Traceback (most recent call last): File "C:\Users\Usuario/.qgis2/python/plugins\openlayers_plugin\openlayers_plugin.py", line 50, in addLayer self.__plugin.addLayer(self) File "C:\Users\Usuario/.qgis2/python/plugins\openlayers_plugin\openlayers_plugin.py", line 204, in addLayer layer = OpenlayersLayer(self.iface, self.__coordRSGoogle, self.olLayerTypeRegistry) File "C:
    – user26694
    Commented Feb 7, 2014 at 13:04
  • The error message complains about a proxy port. Try again without a proxy setting.
    – AndreJ
    Commented Feb 7, 2014 at 15:36

3 Answers 3

1

I had a similar problem, which was caused by QGIS not being able to connect to a network to access the internet (ie, I needed to route through a proxy server but QGIS 2 did not pick up the default proxy settings). I resolved the issue by going to Settings>Options>Network and adding in the proxy server details and login credentials.

I am not sure if this is the same problem as what you are encountering, but the symptoms sound familiar, so it is worth checking.

0

It seems to be a problem on the Windows 64bits version of QGIS 2.0.1. A colleague was able to run the plugin on the 32bits version.

Other solution : using the TMS source via GDAL.

1
  • Thanks for your reply. I work on Windows 7 64bit. My friend use the same operation system and plugin works correctly. I dont know where is the problem. Openlayers plugin is installed but it is not in the list of others installed plugins.
    – user22815
    Commented Oct 10, 2013 at 17:06
0

I had the same problem and i solved in this way:

Go to Setting>Option>Network and deflag the voice "use a proxy for the web" (o something similar, I use Italian version) in the bottom part of form and it work fine.

Byr

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.