3

I have just upgraded QGIS to 2.0 and now I can't load my SID raster layers. I now remember that getting them into 1.8 was a performance but I can't remember all the details.

I have downloaded the latest SDK from Lizard -- I can remember that much and spent some time with google to try and figure out what to do next but I can't even find the 1.8 instructions.

3

If you use a Mac and QGIS from KyngChaos, then download the MrSID plugin of KyngChaos: Framewoks

enter image description here

3
  • Doesn't appear to exist anymore...
    – Max
    May 23 '14 at 19:00
  • If you want GDAL 1.10, go to KyngChaos: Unix Port Download Archive
    – gene
    May 27 '14 at 15:12
  • The KnygChaos framework now contains a MrSid plugin for the current GDAL 1.11. You need the Lizardtech SDK as mentioned in the text.
    – AndreJ
    Jul 17 '15 at 7:50
2

You should install QGIS with the OSGeo4W Installer. In the installer, click advanced install, click next .. next.. and when you arrive at the select packages window, expand the libs tree and select the gdal-mrsid lib, click next and QGIS will install with mrsid suppport. That's it!

1
  • 1
    Sorry, one vital bit of info I forgot. I am working on a Mac. All the stuff I turned up with google referred to OSGeo4W Oct 10 '13 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.