5

I am trying to get an instance of Geonetwork configured but I can't get base layers to display in the Map Viewer as shown below:

enter image description here

I think problem has to do with the fact that I installed Geoserver before Geonetwork so the default WMS base layers that Geonetwork uses where not set up. Is there a script somewhere that will add these or do I need to do it manually?

7

There is a file inside your installation path where you can customize your base layer/s and servers: WEB-INF/config-gui.xml. It contains some instruction about this configuration.

You can define base layers for both the mapSearch (the smaller one) and the mapViewer. Here's an example from a working Geonetwork config:

<mapSearch options="{    projection: 'EPSG:4326',     units: 'degrees',     restrictedExtent: new OpenLayers.Bounds(-63,-27,-57,-22),    }">
  <layers>
     <layer server="http://wms.ign.gob.ar/geoserver/wms?" tocName="Capa Base IGN" params="{ layers: 'IGN:limite_politico_administrativo_lim,IGN:localidad',     transparent: 'true', format: 'image/png'}" options="{isBaseLayer: true}" />
  </layers>
</mapSearch>


  <mapViewer options="{    projection: 'EPSG:4326',      units: 'degrees',     restrictedExtent: new OpenLayers.Bounds(-63,-27,-57,-22)    }">
    <layers> 
      <layer server="http://wms.ign.gob.ar/geoserver/wms?" tocName="Capa Base IGN" params="{      layers: 'IGN:limite_politico_administrativo_lim,IGN:localidad',       transparent: 'true',       format: 'image/png'      }" options="{isBaseLayer: true}"/> 
    </layers>
  <scales values="[7500000, 5000000, 2500000,  1000000, 750000, 500000, 250000, 100000, 75000, 50000, 25000, 10000, 7500, 5000, 2500, 1000]"/>
  <!--scales values="[]" /-->    
  <proj>
    <crs code="EPSG:4326" default="1" name="WGS84 (lat/lon)"/>
  </proj>
  <servers>
    <server name="NASA JPL OneEarth Web Mapping Server (WMS)" url="http://wms.jpl.nasa.gov/wms.cgi?"/>
    <server name="NASA Earth Observations (NEO) WMS" url="http://neowms.sci.gsfc.nasa.gov/wms/wms?"/>
    <server name="DEMIS World Map Server" url="http://www2.demis.nl/mapserver/wms.asp?"/>
    <server name="IDEF servicio WMS" url="http://idef.formosa.gob.ar/servicios/wms?"/>
  </servers>
 </mapViewer>

Hope this helps. Regards

Cristian

  • @dblanchett after placing the geoserver war file in webapps I am able to open geonetwork. But after removing geoserver from webapps it is working – Vikram Jul 23 '14 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.