3

When I registered a database data store to ArcGIS Server in ArcCatalog, the following error occurs:

The connection property set was missing a required property or the property value was unrecognized. Underlying DBMS error [Unknown errorNo extended error.]

I set up the ArcGIS Server and Oracle on two computers as follow

192.168.1.51

ArcGIS for Server 10.1 64bit
ArcCatalog 32bit
Oracle Instant Client 11.1.0.7 32bit
Oracle Instant Client 11.1.0.7 64bit

192.168.1.52

Oracle Database 11g Enterprise Edition 11.1.0.7.0 64bit

I have successfully made the Oracle 11g "Enabled Enterprise Geodatabase" through the ArcCatalog, and it seems nothing wrong.

I added the publisher database connection with the following variables

Database Platfrom: Oracle
Instance: 192.168.1.52:1521/orcl
Authentication Type: Database authentication
User name: sde
password: sde
[v] Save user name and password

And I have added the Oracle Instant Client directory to the PATH and environment variable, I am sure that the 64-bit DLL is found before the 32-bit one. But I still get the error message.

I am wondering if there is anything else I have to set up?

  • Try adding ArcGIS Server Account as your user in the database. You can use GP tool Add Database User for that. ArcGIS Server uses this OS account to make sure the database itself is reachable. – Alex Tereshenkov Oct 14 '13 at 18:35
  • Did you stop and restart the AGS service since the PATH variable change? – Vince Oct 14 '13 at 19:19
  • Thanks for commenting. I've added the ArcGIS Server Account and OS Account as database users, granted CREATE SESSION, CREATE SEQUENCE, CREATE TRIGGER, CREATE VIEW, CREATE TABLE, CREATE PROCEDURE to users, and restarted the service. But I still get the same error message. – Charlie Liu Oct 15 '13 at 1:58
  • 1
    Did you add ArcGIS Server Server Account by running the GP tool? It grants the privileges needed to connect to the database automatically. You might need to restart ArcGIS Desktop application you work in and perhaps the AGS service, too, just to make sure. Do you use domain account for ArcGIS Server Account? Then it should be no problem. If you have local ArcGIS Server Account on one of the machines, then you need to create the identical copy of your local ArcGIS Server Account on another machine, too. – Alex Tereshenkov Oct 15 '13 at 5:57
  • Thank you @Alex Tereshenkov, I've solved the problem by copying the files in Oracle Instant Client 11.1.0.7 64bit folder directly to C:\Program Files\ArcGIS\Server\bin since without file name conflicts – Charlie Liu Oct 15 '13 at 7:14
1

Problem solved by copying all the files in \Oracle Instant Client 11.1.0.7 64bit\ folder directly to <path to ArcGIS Server>\bin\, then restarted the service and successfully registered database.

Since I can start SQL plus by using the command sqlplus sde/sde@orcl in cmd window, I am sure that the environment variable PATH and TNS_ADMIN are both works. But somehow, it doesn't work properly for ArcGIS Server even after reboot or restart service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.