3

The data comes from Geofabrik's Brazil slice: http://download.geofabrik.de/south-america/brazil.html

Imported into a PostGIS DB with osm2pgsql. GeoServer is 2.4.0, running on latest Tomcat 7.0.x, on latest Oracle JVM, on CentOS 64 bits. The GeoServer VM has 1GB RAM and 100 GB disk.

I defined a layer group having planet_osm_line, planet_osm_point, and planet_osm_roads.

I try to seed the cache on this group with the following parameters:

  • Grid set: EPSG:900913
  • Format: image/png
  • Zoom start: 0; Zoom end: 15

When I press Submit, it shows the created tasks, but when I come to the seed page again, there's none. And the CPU isn't being used.

The GCW demo does work and it seems to be feeding the cache. When I use that, I can see the heavy usage on top.

Another thing: after panning through the map in the demo for a bit, the cache directory is populated with PNGs and has 19 MB. But in the Tile Layers screen, "Disk Used" still shows 0.0B. What's happening?

0

To see more than 0.0B you must go into GeoWebCache Settings and to set Enable Disk Quota limits.

For a (long time visible) working task you need to go to your layer group in Tile Caching -> Tile layers and to verify the available gridsets. You must check both (Min/Max) Published zoom levels and Cached zoom levels, to be sure that you don't seed the tiles just for a single/a few zoom level(s).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.