3

I am a new to the field of GIS-Software. So i hope for your patience. English is not my native language so sorry for that too ;).

My overall goal is to export a DXF-File with just the special objects with a special attribute for importing it into Vectorworks.

I have imported a shapefile in QGIS with the "add vector layer feature". I have a really big file with around 650.000 objects/features. I want to delete a lot of them with a special attribute in the attributes table with editing mode. I tried with QGIS and Arcgis and both are using 100 % CPU for a long time (2-5 hours), and nothing happens. I did that some weeks ago with that procedure i described above but now it doesn't work anymore because both programs "die on it".

What am I doing wrong? Is there another way?

4

I wouldn't delete them that is just unneeded overhead for no gain.

I would simply select the ones you need and do Layer -> Right Click -> Save Selection As.. to save the selected features out to DXF.

3

In QGIS turn off the rendering option (right bottom corner) before you add data. After import data rightclick on the layer on the table of content and make an inquiry. This will filtr your table without viewing it. Then try to open attribute table. Good Luck!

2

So the combination of both comments worked. I turned off the render function first, imported again, right-clicked on the layer, made it through the filter-function and also managed to select severall values of the same field! Then saved-as with the right-click as dxf. Thank you both!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.