2

I have tried to use the Processing Toolbox in QGIS 2.0.1 a couple of times now (using SAGA and OTB) and in both cases the processing tools always return an error along these lines:

"Problem loading output layers: The following output layers could not be open(ed) - Output image: D:/Temp/output.tif

The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm. Checking the log ... etc."

When I dismiss the error the original tool's window also closes, giving me no opportunity to check the log.

This is a brand new Windows 8 installation with a brand new QGIS installation (via the OSGeo4W online installer). D: is writeable and I have set up folders for the OTB toolbox.

What else should I do to get these toolboxes to work?

  • 1
    I have had similar issues trying to use the processing tools. After some investigation it turned out I was using invalid inputs for the particular tool and it was unable to create a valid output file. I have noticed that SAGA GIS is particularly sensitive. Try double checking your tool parameters and make sure they are in line with the documentation.Not sure if this is the issue you are having, I use windows 7 and everything seems to be working fine for me. Hope this helps. – G.Oxsen Oct 16 '13 at 15:50
  • Please provide information on which tool and which input values you are using. – underdark Oct 16 '13 at 16:32
  • Thanks G.Oxsen and underdark. I have to admit it wasn't a big priority for me at the time other than checking out the new toolbox. I had only just upgraded to QGIS 2 after setting up my new computer. I should be able to get onto it again later this week. – Frank Oct 20 '13 at 8:18
  • underdark, I had tried the simplest OTB tool I could find: Image Manipulation > Read image information. The image in question was a multispectral Landsat scene in ER Mapper ERS format, already displayed in the QGIS canvas. G.Oxsen, the OTB documentation doesn't help me one bit in this example since nothing in it matches what I see on the dialog. – Frank Oct 20 '13 at 8:24
3

It may have to do with some conflict between the two versions of SAGA (2.0.8 and 2.1). When unchecking the box 'Enable SAGA 2.0.8 compatibility' in Settings and configuration, it solved the problem for me. I´m using QGIS 2.0.1 Dufour with SAGA 2.1 on Windows 7 64 bit. Hope this will help.

  • Thanks Jonas. Where is this Settings and Configuration option? Is it in SAGA or QGIS? I notice that I only have SAGA 2.0.8 installed, so perhaps that is the problem. It doesn't explain the OTB problem though. – Frank Oct 20 '13 at 8:21
  • Sorry for not being precise. You find 'Options (not settings) and configuration' in the QGIS menu under Processing. Choose Providers and then SAGA. – Jonas Sjögren Oct 20 '13 at 15:01
  • Just some complementary information. When you have downloaded SAGA 2.1, replace the SAGA folder in the QGIS Dufour folder with the one you just downloaded and make a system reboot. – Jonas Sjögren Oct 22 '13 at 7:21
  • 1
    Jonas, I think your advice is correct. I will respond properly once I have tested your suggestion. – Frank Oct 24 '13 at 0:30
2

I think that you should open a bug on the qgis tracker. Try to add as much info as possible regarding the version and the installation procedure for SAGA and OTB.

HIH

  • Are you using SAGA GIS and OTB from the osegeo4w? – Filipe Dias Oct 16 '13 at 12:33
  • Filipe, yes they are all from the osgeo4w. – Frank Oct 24 '13 at 0:30
0

I had this error for the SAGA tools.

Finally, it worked by downloading the newer SAGA version (2.1.4) from the homepage and defining the path under "Processing" - "Options" - "SAGA" - "SAGA folder" like C:\Program Files\saga_2.1.4_x64 but it also works as Jonas Sjögren wrote above by copying the downloaded folder into the apps folder and rename it to saga (eventually keep the old saga-folder by renaming it)

I have Windows 7 and QGIS 2.8.1

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.