3

I followed this tutorial: http://anitagraser.com/2012/04/06/qgis-server-on-windows7-step-by-step/ but nothing happens.

enter image description here

And when I try to open it this error message appears enter image description here

So I tried to follow httpd_qgis.conf edition step from http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial but it gives me the same error.

enter image description here

I think I didn't need that step because I can see "mod_fcgid" in my apache modules directory

enter image description here

What am I doing wrong?

  • Had the same problem and solved adding C:\OSGeo4W\bin to the system path – user2030490 Dec 17 '13 at 14:24
1

I solved this problem by manually installing the fcgi package in OSGeo4W.

according to this ticket:

http://trac.osgeo.org/osgeo4w/ticket/395

the package should now be selected as dependency by default.

0

I compared my version (that works on Windows 7)

localhost/qgis/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1.3.0&SRS=EPSG:4326&REQUEST=GetMap&map=C:/OSGeo4W/apps/qgis/bin/QGIS_WEBPROJECT.qgs&BBOX=49.5311,-123.4173,49.5211,-122.1973&WIDTH=1000&HEIGHT=1000&Styles=default&LAYERS=LAYERNAME_WGS84&FORMAT=image/png

I have a project saved in the directory

C:/OSGeo4W/apps/qgis/bin/QGIS_WEBPROJECT.qgs

(is in WGS84) a bounding box (Vancouver)

Image height/width (pixels format)

Result enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.