3

Using ArcGIS Desktop Advanced 10.1

I have a large CSV file (36MB with about 600,000 records) that contains single addresses that I want to geocode. The file is called "SingleAddresses.csv" The file contains 5 fields. When I first loaded the file into ArcMap, I had misnamed some of the field names, and so my field names were "SegID", "FromStNo", "Zone1", "Zone2", "Zone3". So I closed ArcMap, reopened my file in Notepad++, changed the field names to "Address", "City", "Zone1", "Zone2", "Zone3". However, when I open up ArcMap again and add the SingleAddresses.csv file again, the old (original) field names show up.

It seems as though ArcMap is caching the field names for the "C:\My Files\SingleAddresses.csv" file. If I move that file to a different directory and then open it in ArcMap, the field names show up correctly. If I keep that file in the same directory but rename it (SingleAddresses2.csv) and then open it in ArcMap, the field names show up correctly. But as long as I keep the same file name in the same directory, it still shows the old field names, even if I delete the original file and create a new empty SingleAddresses.csv file. It also still shows the old field names if I import that file into a new (different) map.

Note that I cannot duplicate this if the original file is a small file. The problem only occurs if the file that I originally use is "big"...

Is there a cache somewhere that I can delete that would eliminate this problem? It seems as though ArcMap caches the field names for a hard-coded file name. It is really annoying...

  • 1
    do you have xx files in C:\Documents and Settings\<user_profile>\Local Settings\Temp or C:\Users\<user_profile>\AppData\Local\Temp resources.arcgis.com/en/help/main/10.1/index.html#//… – Mapperz Oct 16 '13 at 19:15
  • Nothing relevant that I can see... a few files with modified dates in the last couple of days, but none related to ArcMap... – Jason Miller Oct 16 '13 at 23:12
2

If you see a schema.ini in the same folder as your .csv, delete it.

1

go to the options in arcmap and clear the cache.
cache

  • Sorry, forgot to mention that I already tried this... doesn't work... I tried to clear the cache and then reload it without closing ArcMap, and also clearing the cache then restarting ArcMap... neither solved the problem... – Jason Miller Oct 16 '13 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.