I'm using QGIS to make maps with OSM streetmaps data. Problem is that with QGIS -> Vector -> OSM -> download data, after about 13MB I get "Download error Operation cancelled". Sometimes I get "Download successful" after 8MB but can't import the .osm because of "XML error, Premature end of document". I reduced the areas of the download to keep the size down and two out of five were incomplete files. With Maperitive I've downloaded bigger files, from rambler.ru. Is there some setting in QGIS to change the source of the data? Or some other way of solving the problem?


Funny enough, I have been running into the same issue tonight and fixed it in this commit


The problem is not related to the server or size, but happens due to a network timeout which by default does not take into account, that data is actually being transferred. The above-mentioned commit solves this, so it should be soon in any nightly/master build.


Go to Settings=>Options=>Network and increase the Timeout for network requests (ms) to be large enough to transfer all the data.

  • 1
    That works sometimes. Increasing the timeout to 5 minutes I got 48MB intact. Next 2 downloads I got one "cancelled" at 24MB, then one "successful" (at 15MB) which was incomplete.
    – user23029
    Oct 18 '13 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.