i worked in an application vb.net , arcengine : i copy the project source and i paste it in other Machine , Ooops i can't compile it , Error is :

Error 1 Could not load file or assembly 'file :/ / / C :/ Program Files (x86) / ArcGIS/DeveloperKit10.0/DotNet/ESRI.ArcGIS.ADF.Local.dll' or one of its dependencies. Attempt to load a program with an incorrect format. Line 142, position 5. C: \ Users \ m\ Documents \ Visual Studio 2010 \ Projects \projetc1\reco.resx 142 5 recM

any suggestion ?

  • Questions: 1) have you installed the WebADF 10.0 on the new machine? 2) Are both machines 64-bit? 3) Are you also upgrading from one version of the WebADF to another as part of this change?
    – tomfumb
    Oct 25, 2013 at 19:31
  • You could first try going to the project's references and removing all ArcGIS DLLs (make a list / screenshot before you do this). Then use the VS dialog to add references and get them all from the new machine's GAC (assuming they are in there)
    – tomfumb
    Oct 25, 2013 at 19:33
  • 2
    This could be a 32-bit vs 64-bit issue. Does compiling specifically for x86 (i.e. 32-bit) help?
    – Petr Krebs
    Oct 29, 2013 at 20:29
  • Did you try setting the target platform for all build configurations to x86?
    – Petr Krebs
    Oct 31, 2013 at 21:22

2 Answers 2


1) Remove the reference "ESRI.ArcGIS.ADF.Local.dll" and then add reference from new machine. The error may occur due to change in path of the DLL in the new machine. 2) Check the .Net Framework in both machines, if there is a mismatch, change references accordingly. 3) If both these options do not work, then check that the DotNet SDK is installed properly in the new machine. This can be checked by creating a new project and giving reference to the "ESRI.ArcGIS.ADF.Local.dll" and check whether you are still getting same error.


You will need to make sure the ArcGIS SDK is properly installed on the new machine. It appears that the Microsoft.Net runtime is not able to properly resolve either the libraries or a proper license to use/run the application.

The proper license being available will often stop a lower level DLL from initializing which can cause the Local to never init.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.