1

There is a new Apple Release of OSX called Mavericks and my questions are:

  • Will GDAL run?
  • Will QGIS run?
  • Will Tilemill run?
  • Will Mapnik run?
  • Also are there any known issues?

A similar question about Mountain Lion.

  • @Jason, I wrote GIS because it was not only about QGIS. – oskarlin Oct 22 '13 at 23:36
  • How could I edit the question to make it less "opinion-based"? I don't get it. – oskarlin Oct 23 '13 at 8:49
  • I don't think that this should necessarily have been closed as "opinion-based" but I certainly think that it is too broad to be re-opened. I suggest reviewing What makes a good question? and then start by asking whether just one of these software products will run under this OS version. Also, include what research you have already done to try and ascertain that. – PolyGeo Oct 23 '13 at 21:32
  • Well I don't want to write one question for each application, that would spam this site too much. Also the reason I am asking these questions is because I haven't installed Mavericks yet and I don't want to do that until I know it's OK to do it. So what should I do? – oskarlin Oct 23 '13 at 21:36
  • 2
    My advice is still more or less the same. I would start by asking four questions as four Questions. The first would be "Has anyone successfully run GDAL under Apple Release of OSX called Mavericks?" and state at the outset that you are asking to determine whether you should try to. You should also say that you have searched the Apple SE site unsuccessfully (if that is the case). Personally, I would not state "one application/issue in one answer" but if I were to Answer I would either say "Yes, works fine" or "No, I had this issue". – PolyGeo Oct 23 '13 at 21:51
1

QGIS 2.0.1

Tried to start it up gave two errors:

First error

Couldn't load plugin openlayers_plugin due an error when calling its classFactory() method

Traceback (most recent call last):
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 204, in startPlugin
    plugins[packageName] = package.classFactory(iface)
  File "/Users/ustroetz/.qgis2/python/plugins/openlayers_plugin/__init__.py", line 25, in classFactory
    from openlayers_plugin import OpenlayersPlugin
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 453, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/Users/ustroetz/.qgis2/python/plugins/openlayers_plugin/openlayers_plugin.py", line 35, in 
    from openlayers_ovwidget import OpenLayersOverviewWidget
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 453, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/Users/ustroetz/.qgis2/python/plugins/openlayers_plugin/openlayers_ovwidget.py", line 36, in 
    import bindogr
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 453, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/Users/ustroetz/.qgis2/python/plugins/openlayers_plugin/bindogr.py", line 1, in 
    from osgeo import ogr, osr
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 453, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
ImportError: No module named osgeo

Python version:
2.7.5 (default, Aug 25 2013, 00:04:04) 
[GCC 4.2.1 Compatible Apple LLVM 5.0 (clang-500.0.68)]


QGIS version:
2.0.1-Dufour Dufour, f738351

Python path: ['/Applications/QGIS.app/Contents/MacOS/../Resources/python', '/Users/ustroetz/.qgis2/python', '/Users/ustroetz/.qgis2/python/plugins', '/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC', '/Library/Python/2.7/site-packages']

Second error

Unable to load GdalTools plugin. 
The required "osgeo [python-gdal]" module is missing. 
Install it and try again.

QGIS started up fine. OpenLayers Plugin wasn't there anymore though. After trying to reinstall the OpenLayers Plugin I code the following error:

The plugin depends on some components missing on your system. You need to install the following Python module in order to enable it: osgeo

After reinstalling GDAL everything worked like before. No more errors.


GDAL

no Problems so far, works fine

Tilemill & Mapnik

don't use them

|improve this answer|||||
  • 1
    Thanks! I heard form last update that it's good to reinstall GDAl etc from Kyngchaos after a major OS update. Did you do this? – oskarlin Oct 22 '13 at 23:23
  • @OskarKarlin Thanks for the hint. Reinstalled GDAL and it works like before. – ustroetz Oct 22 '13 at 23:28
  • You mean QGIS? Or GDAL? You said "no Problems so far, works fine" with GDAL – oskarlin Oct 22 '13 at 23:34
  • It didn't experience any problems with GDAL before reinstalling it. Though reinstalling GDAL fixed QGIS (QGIS uses GDAL). – ustroetz Oct 22 '13 at 23:39
  • @OskarKarlin One question (in this case product) per Question would have made the product being talked about here obvious. Trying to Answer multiple questions in a single Question invariably gets messy and GIS SE strives to provide clean Q&A. – PolyGeo Oct 23 '13 at 21:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.