-2

I need help with how to add access to my computer. When I edit the pg_hba.conf i still get the access denied error. I just want to give a specific ip access to all db and all users from that ip... no encryption.

I am using opengeo suite 3.0.2 and pgsql 9.1.

closed as unclear what you're asking by PolyGeo Aug 12 '16 at 3:34

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

A few things would be helpful:

  • the error message you are getting back when trying to connect
  • the entry you set up in pg_hba.conf

But basically you should be able to enable the remote connection by:

  1. Add the entry for pg_hba.conf for the IP and user, with "trust" as the authentication method.

  2. Ensure that postgresql is listening on all network interfaces, and not just localhost. You can do this in postgresql.conf, just serach for the "listen_addresses" parameter.

Not the answer you're looking for? Browse other questions tagged or ask your own question.