2

I'm migrating my ArcGIS map services from version 10.0 to 10.2. It uses ArcSDE to manage spatial data in a SQL Server database. I was able to create the map service and everything seems OK. However if I add a sub-query in the WHERE statement of a query form in any map service, I receive "Unable to complete operation." error as the following image: enter image description here

The same query was working in ArcGIS server 10.0. Also I can run the same query to select data, when I use the map document directly from ArcMap 10.2. The ArcGIS Server 10.2, ArcSDE, and SQL Server are installed on a server which is internally accessible from the web server. The ArcGIS Web Adaptor is installed on the web server. Both servers have windows Server 2008 and IIS.

I appreciate your advice. Thank you

  • 1
    What does the actual code that makes the query look like? – Vince Oct 25 '13 at 17:13
  • Please click here to see the Query form for the service. – Fred Oct 25 '13 at 17:20
2

I found this article About standardized queries. It says that sub queries are not supported using standardized queries. But standardized queries can be disabled. I'm not sure if that means sub queries will work if you disable standardized queries though.

  • I disabled the Standardized Queries and it works now. Thank you. – Fred Nov 14 '13 at 0:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.