0

This question already has an answer here:

hopefully some of you have got an answer to what happens to me when i run (so far) all the processing tools for carrying out raster analyses.

This is the type of message i receive from QGIS (2.0.1 Dufour).

Notice that i am running qgis on windows 7 and i have checked SAGA, it is activated and all items are ticked "on".

Suggestions are welcome :)

Many thanks! enter image description here

marked as duplicate by underdark Dec 29 '13 at 19:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is this a general error? If other simpler SAGA algorithms run then this error might be the result of wrong parameters/formats. Try to execute the command in standalone SAGA (saga_gui.exe) – Curlew Oct 29 '13 at 23:25
  • Hi Curlew, yes this is a general problem. I have a dataset of points and i am trying to interpolate them. no matter the interpolation function i use i can't display the results. For instance if i read the log of IDW it says "GDAL export raster could not initialise data objects. the file could not be opened". – ilaria marengo Oct 30 '13 at 10:40
0

I had the same error message running SAGA vector algorithms. You may have tried this, however, to get the algorithms to run (using QGIS Dufour and SAGA 2.1 - ships with the QGIS 2.0.1 windows standalone installer), I needed to ensure that the option to "Enable SAGA 2.0.8 compatibility" within the processing configuration and options settings was turned off (unchecked). I also had to alter the folder path to where the saga.gui was located following the standalone installation of GIS. I then restarted QGIS, and the algorithms worked.

Hope it assists.

  • Hi Stephen, thanks a lot!!! it works for some tools. i am struggling with kriging now. i still get a message error. Perhaps could you explain better the change of folder path that you made? thank you – ilaria marengo Nov 1 '13 at 12:03
  • Hi Ilaria, Under the "Providers" setting (processing - options and configurations) I recreated the path on my computer to: C:\SAGA\saga_2.1.0_win32\saga_2.1.0_win32, to the folder where the file sags.gui is retained. – Stephen Nov 4 '13 at 22:39
  • Hi! so i checked the path under the provider and it matched with that one where the saga.gui is saved. In my case is C:\Program Files\QGIS Dufour\apps\saga. I didn't installed SAGA as standalone software. Should i have done it? – ilaria marengo Nov 6 '13 at 12:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.