1

I tried the following in QGIS with the Grass Plugin:

r.cost input=preCostSurface@albi start_points=OSMroads@albi output=cost0109 max_cost=0

And I get the following error:

Dev note: Adapted sites library used for vector points. (module should be updated to GRASS 6 vector library)

No start points 
Finished with error

What is causing that and how can I fix it?


Edit: It seams like this is a general Grass 6.4.3 issue and will be resolved in Grass 7. Does anybody know a workaround for that problem meanwhile?

2

The r.cost GRASS module expects start_points to be a map containing point features. It seems that your map doesn't contain any point features. Try using a map with point features. With QGIS you can easily digitize such a map.

For more information on the parameters see the r.cost manual page for GRASS 6.4:

  • r.cost.rast takes as input a raster map with starting points. In other words a raster map where all non-NULL cells are considered to be starting points. Is this what your OSMroads map is? – Wolf Bergenheim Oct 31 '13 at 23:51
  • You are right. I used a line vector layer. I thought that works too. But it doesn't. It only accepts points. I converted the line layer to a raster and used r.cost.rast. This way it worked. – ustroetz Nov 4 '13 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.