I am using QGIS 2.0.

I'm trying to import a text delimited layer using lat/lon, but the tool interprets the data as a single line. I've tried saving my csv using several different programs (Stata, python editor, text editor, Excel), but nothing works.

Here is a sample of my data:


And my csvt file:

"Real", "String", "Real", "Real"

This is what the dialog box looks like when I try to upload. You can see there is no data because everything is pulled into row 1:



3 Answers 3


In Mac OS X Excel, save as "Windows CSV" instead of the Mac CSV option and Add Delimited Layer should now recognize the data


This is a known issue on OSX. See this bug report for updates: http://hub.qgis.org/issues/8421

Side note: The Add delimited text layer plugin does not use the .csvt file. The .csvt file is only interpreted by OGR - that means when you load the .csv using Add vector layer.


I should add that the 'save as windows CSV' fix worked for me, except I couldn't just re-save the same file as Windows CSV. For some reason I had to copy the contents of the previous CSV file into a new spreadsheet "save as Windows CSV", and finally it imported correctly into QGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.