4

We have a problem with a shapefile feature class. Periodically it will not save edits with an error message as the following:

Cannot save edits; cannot acquire a lock

Working in 10.1 with a water main shapefile (with about 5 other users on different workstations viewing the layer). It has been suggested to us that the toplogy/rules associated with the layer is causing the problem.
Does anyone know if this might be the problem and or has a solution?

  • is the shapefile shared and viewed by 5 workstations ? – geogeek Nov 4 '13 at 14:22
  • 3
    Shapefiles can only have map topology. Geodatabase feature classes have topology rules. If it is a shapefile any other user in ArcMap or ArcCatalog can lock it up. If it is a geodatabase feature class in a topology any other user of any feature class in the feature dataset can lock all the features classes in the dataset up. In addition even if they remove the feature class from their project the lock will remain until they close ArcMap. Sometimes that happens with shapefiles too. – johns Nov 4 '13 at 15:37
  • just close arccatalog...............:) – user37867 Oct 7 '14 at 8:30
2

If you are trying to edit a shapefile you will have to have exclusive access to the file (no other users accessing it) in order to get the lock for editing.

You can see this question about how to "kick them off". Alternatively, you could just ask your co workers to stop using the shapefile while you edit.

  • Ok...but I've been able to edit the shapefile feature class without problem when multiple other workstations were viewing the layer. It seems random when the lock comes up. – Daniel Hester Nov 4 '13 at 16:07
0

I think you can find your answer in below links: Cause: The issue occurs if one or more processes attempts edit a shapefile or feature class simultaneously. Based on ESRI documents.

Problem: Unable to edit a shapefile or feature class in a file geodatabase

Unable to Save Edits - failure when flushing edits to databas

File geodatabases and lockin

0

This seems to be a general file lock issue as ArcGIS expects exclusive file locks on shapfiles and file geodatabases. Check any %computer-name%.lock inside the folder to find which computer is using this file.

However, if anyone like me came here to looks for a solution for cases in which files being stored on NAS or other network storage, you might want to check your OS ver. (win7 and win2008) and disable SMB2 Caching as @lior has suggested.

ESRI Doc has describe this caching system would refresh the remote folder only every 10 secs while ArcGIS would check the success of file locking by looking after the .lock file almost instantly.

To disable the caching on win7 and win2008, update your registry by creating a new dword entry and reboot.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
"DirectoryCacheLifetime"=dword:00000000

Ref:
Microsoft's Doc about this

0

Has ArcMap crashed on you recently while editing or viewing that dataset?

I edit 8 hrs per day and have found that when ESRI crashes while editing, it does not always release the lock I had on the dataset in the previous crashed session. Perhaps a process remains active in the background or something?

In these cases, step one for me is to restart my machine to be sure no weird ESRI processes are running in the background. Step two is for me to browse into the the folder where the shapefile is (or even in to the .gdb folder) in Windows explorer and manually delete any LOCK files still in there. I have found years old lock files hanging around from former employees somehow!

-1

Problem accord because of the difference of CACHE speeds between windows and NAS server.

A regedit change will fix the problem: Solution

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    Please expand on your answer--links can become broken, so it's best not to rely on the link only. – MaryBeth Jan 3 '17 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.