7

I imported the coordinates from an Excel table. They show as single points as intended. Now I want to add columns to the attribute table, but I'm not able to edit it. I wanted to import the following columns from Excel as well, but that doesn't seem to work either.

Sorry for the noob-question, but I couldn't find anything relating the theme through google and such.

Ok, with pictures then: I want to use that to add columns with information to these

enter image description here enter image description here

You see, the small pensil thingy is greyed out, so I can't edit anything in this layer and I can't add any information to my points.

If I try Ale suggestion I get this error:

enter image description here

  • If I understand well you do not need to export coordinates from QGIS to excel, you con view point coordinates using the field calculator – Ale Nov 4 '13 at 14:49
  • Have you tried to save your layer in a new one and try to edit the second one? – Ale Nov 4 '13 at 16:15
  • Not entirely sure what your problem is, but if you imported your data using add delimited text as layer then it may be related to settings for your import. From what I can remember you might need to have the_geom column in your table in order to enable editing. In any case you might want to try looking at a plugin called quickmultiattributeedit – Carl Carlson Nov 4 '13 at 16:26
15

By default CSV layers cannot be edited. You have to save to a different format, e.g. Shapefile, before you can start editing.

Update 2015-11:

There's a new plugin that solves this issue called Editable GeoCSV. It can handle x and y columns for points or a WKT column. For more details see http://giswiki.hsr.ch/Editable_GeoCSV_QGIS_Plugin

  • 1
    Wow, I think that nailed it. Save the layer as ArcGIS Shape. Then delete old Shape. Then reopen as new vektorlayer. Seems to have worked. Full acces to edit mode with the attributes. :) Thanks, guys! – user23609 Nov 4 '13 at 19:13
  • Still has the bug, edits made from the "Identify Tool" dialog don't work. Instead, open the Attribute Table and edit in there. See github.com/geometalab/Editable-GeoCSV-QGIS-Plugin/issues/2 Using QGIS version 2.14.2-Essen – BillW May 13 '16 at 0:05
3

Save as Geopackage solves the problem in QGis 2.18

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.