2

I want to install some GRASS-Addons to use them in QGIS. Therefore I run GRASS-Plugin in QGIS an open the GRASS-Shell type: g.extension

GRASS opens then i go to "optional", activate "System installation" and type the extensionname "r.viewshed.cva"

after this I run the whole thing and get the following output:

(Tue Nov 05 15:53:05 2013)
g.extension -s extension=r.viewshed.cva svnurl=http://svn.osgeo.org/grass/grass-addons/grass6 which: wget: unknown command WARNING: GRASS_ADDON_PATH is not defined, installing to ~/.grass6/addons/ Fetching from GRASS-Addons SVN (be patient)... A r.viewshed.cva\description.html A r.viewshed.cva\Makefile A r.viewshed.cva\r.viewshed.cva.py Checked out revision 58151. Compiling ... C:/OSGeo4W/apps/grass/GRASS-~1.3/include/Make/Grass.make:423 : warning: overriding commands for target C:\Users\Warsow\.grass6/1/addons/.tmp/1084.0/dist.i686-pc- msys/bin' C:/OSGeo4W/apps/grass/GRASS-~1.3/include/Make/Grass.make:414 : warning: ignoring old commands for target C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686-pc- msys/bin' make: C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686 -pc-msys/tools/g.echo.exe: Command not found make: C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686 -pc-msys/tools/g.echo.exe: Command not found mkdir -p C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686-pc-msys/bin mkdir -p C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686-pc-msys/include/grass mkdir -p C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686-pc-msys/etc mkdir -p C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686-pc-msys/driver mkdir -p C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686-pc-msys/driver/db mkdir -p C:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686-pc-msys/fonts make: *** No rule to make target r.viweshed.cva.py', needed byC:\Users\Warsow.grass6/1/addons/.tmp/1084.0/dist.i686 -pc-msys/scripts/r.viweshed.cva.py'. Stop. ERROR: Compilation failed, sorry. Please check above error messages. rm: cannot remove directory `C:\Users\Warsow\.grass6/1/ad dons/.tmp/1084.0/r.viewshed.cva': Permission denied (Tue Nov 05 15:53:12 2013) Command finished (7 sec)

I don't know why it doesn't work - could somebody help me?

Win 7 QGIS 2.0 GRASS 6.4.3

3

The solution is given in the r.viewshed.cva.py

It is a Python script and the line 189 is:

 grass.run_command("r.viewshed",....

So you need to install r.vieshed first but most Windows computers don't have a common compiler and a building environment built. The developers compile every night the addon modules for Windows (see Installing an addon in winGRASS 7.0 for complete dummy , it is the same for GRASS GIS 6.4.3). They are in Win GRASS 6.4.3 addons

If you don't want to use g.extension, download r.viewshed.zip and r.viewshed.cva.zip, an unzip in your GRASS_ADDON_PATH (C:\Users\Warsow.grass6/1/addons/? from your output)

  • gene, how do I find my GRASS_ADDON_PATH on my Windows computer? It is not the same as A.W.'s path. – Catlike Feb 10 '14 at 5:56
  • Also, I would not mind using g.extension. However, it says I need to "install Subversion first". I did install Subversion, and re-started the computer. I still get that message upon using g.extension -- "install Subversion first". – Catlike Feb 10 '14 at 5:58
1

Thanks for your help. I downloaded the zipped files and unzipped them into the addon path. It works running them from the GRASS shell in QGIS. unfortunately the addon doesn´t appear in the processing framework. is there any way to manage this? or a way to run r.viewshed as a batch-process?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.