For some reason, the option to add a "New" or "Import" style is grayed out. I tried creating a different dimension annotation feature class with the style I want, and then copy and pasting the records...but the option to copy was grayed out. I have a ton of dimension annotations in the feature class I am trying to change so re-doing it is not an option. Anyone know what is going on?

enter image description here


I am not exactly sure why this solution worked but, I tried opening and closing the properties of my dimension FC several times, and the option to select "New" style suddenly worked. There might have been a lock on the FC, hard to say.

  1. Create a new feature class within a file geodatabase or feature dataset in ArcCatalog
  2. For type choose Dimension Features then create a name then click Next
  3. Choose any coordinate system
  4. Specify any reference scale
  5. Click the "I would like to create my own style" radio button and then select the New Style button next to it.
  6. Click Edit Symbol
  7. Within the Symbol Property Editor Dialog box, in the Type drop-down menu select Character Marker Symbol
  8. Select desired font and symbol
  9. Specify rotation angle
  10. Click Ok
  11. Click Ok in the Symbol Selector dialog box
  12. Notice the change in symbol and orientation in the preview window
  13. User can also change color, XY offsets, and size of the symbols to desired level

Note: This Workaround only is editable the first time. If any additional styles are needed after the initial is created, you can go into the properties for the dimension feature class and click the Dimensions tab, choose the style just created, click new and OK, and repeat the steps above for the workaround.

  • I already tried creating a new FC and copy and pasting the records from my old dimension anno into the new one. This workaround did not work. The problem is that adding a "new" style is not an option for me for some reason. – kkaszas Nov 5 '13 at 23:19

Creating a dimension feature class with a custom style



In order to manage the styles, you must be using a connection which has permissions to modify it AND the layer and dataset must not be in use. Sometimes even your own ArcMap can be the one creating the lock. Make sure no one is using any layer in the dataset, then try again without adding the layer to the map.


Click "stop editing" on the editor tab then try adding new style again.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.