2

I have two separate CAD files of the same locale. The first one has surface data like street curbs, building footprints, etc. It is not georeferenced, but when I add it to other items in a projected (NAD 1983 FIPS US feet Connecticut) data frame, it aligns perfectly.

The other CAD file contains subsurface utilities and a surface basemap as a reference. When I try adding them, they show up very very small not too far from the properly projected data.

When I try to project subsurface layers, they don't show up at all.

Trying to georeference manually gives me an error after I manually attempt to enlarge it using georef toolbar tools, even if I delete the spatial index.

I have ArcGIS 10.1 SP1 and a trial of CAD 2014.

Screenshot displays properties boxes, the surface data on the right, subsurface on the left.

enter image description here

  • It's hard to identify the subsurface coordsys because you're showing the "xy domain" values. They may not reflect the actual data. What extent do you get for that data in a new ArcGIS session? My guess is either it's in meters, or in inches/centimeters. The other data is already in NAD83 CT (USFt) because it lines up without issue. – mkennedy Nov 6 '13 at 1:05
  • By saying it is not georeferenced you must mean there is no projection file? If it is sitting in the right place, it is georeferenced (the dwg is). If you have exported the data to shp file and it doesn't have a prj you can assign one in catalog by right clicking. The subsurface is in a different unit perhaps dd? I use autocad map 3d and can export a shp file with projection. – Brad Nesom Nov 6 '13 at 2:17
  • If you can post them. i can convert in a few minutes – Brad Nesom Nov 6 '13 at 2:22
0

If the DWG does not have spatial reference than you can:

  1. Export the CAD vectors (point, line, or polygon) to a feature class or shapefile
  2. Turn on the Spatial Adjustment toolbar to spatially adjust those vectors to their correct location

Rasters get georeferenced whereas vectors get spatially adjusted.

  • I popped in the "proper" file into a blank map and then added the one I had trouble with. Then used Spatial Adjustment toolbar to get it to align. Yay. It worked when I didn't have a projected coordinate system set in the dataframe. – SpiffyFuture Nov 21 '13 at 19:06
  • One crucial thing... I had to manually export each individual layer from the cad drawing to a geodatabase because the CAD to Geodatabase tool would get stuck and never complete. THEN, I had to export each feature to a shapefile, and only then did the Spatial Adjustment work! – SpiffyFuture Nov 22 '13 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.