4

Do you have specific expertise you could share of examples where an ArcGIS Modelbuilder has worked on one PC but not on another?

Are there any issues between different Windows versions?

There is a related question here Model not editable on a different PC

In my example I have a model that runs to completion on a Windows 8 machine. I run the models from an external hard drive. When the same model is run from the same external drive but on a different PC - Windows 7 then the model crashes.

The model can be opened, edited and verified on both Pc's.

It just crashes on one but not the other.

I have explored possible options:

  • ArcGIS Version and service packs - both are 10.1 SP1.
  • RAM - the PC on which the models work has LESS RAM than the PC on which the models crash
  • OS type - both machines are 64 bit.
  • Model build - I have re-built the model by copying and pasting into new / clean models (I did this on the Windows 8 PC though)

I am not sure that the cause is the different Windows version, it is just the main difference I can see between the two PC's

Any expertise, answers or references to sources of information would be much appreciated.

I am using ArcGIS 10.1 SP1 for Desktop Advanced.

UPDATE:

I have followed all the advice in setting up a shared Toolkit so all folder structure to Scratch, working directory, etc is set to named folders within the Toolkit. So I do not think that was the issue.

Unfortunately at the moment I do not have copies of crash report, etc to post here.

I have reported this issue to Esri, and sent them the relevant models but they were not able to reproduce the issue.

Ultimately, we upgraded our machines to 10.2.2 and we have not had the issue, although the models have been further edited a lot since that time.

I can only assume that it was some issue with 10.1.

  • 1
    Have you tried running the model locally, rather than on a external drive? I understand it may use network data to complete, but if you could setup an instance where all of the data is local (say, everything on your C drive), and see the model still bombs out. – evv_gis Nov 7 '13 at 20:34
  • Hi. Yes I have tried that. The model is set up to reference all data, scratch workspace etc within a single folder. It works from an external hard drive on one PC. On the other Pc's I have tested it on C Drive, on the original external hard drive and also on a USB flash drive. All these did not work. I will now also check that it runs from C drive on the original computer just to be sure. – user21053 Nov 7 '13 at 21:09
  • Can you list all functions/tools your model uses? As for running on the C drive for the original machine, that's not necessary. I was really just interested if you did it on the failing machine. – evv_gis Nov 7 '13 at 21:39
  • Main tools: Create fishnet, Select, Feature to point, Extract values to points, Copy rows, Zonal statistics as Table, Collect values, Add field, Calculate field, Iterate feature selection, Select layer by location, Merge, Select layer by location, Delete, Summary statistics, and Join Field – user21053 Nov 7 '13 at 22:45
  • do both arcgis versions have the same extensions available? – Antonio Locandro Nov 8 '13 at 4:57
1

1) I would suggest that could drive structure / permissions. For example, a working directory is set that exists in the 8 folder structure but not 7. Not inputs or outputs but working or scratch.

2) As above but more likely a user profile structure that is different.

3) Check the error report as this likely tells you what is the exact cause (Geoprocessing > Results)

4) Rebuild just the process it fails on.

5) But my guess is an environment setting on 7 as opposed to 8.

6) Check build numbers (they can differ slightly even if SP is the same).

0

In a case like this one, where you have already been able to package your data and model to transport it another machine for testing, my recommendation would be to consider contacting Esri Support and offering to send them the package.

This is because they should be able to:

  • test the same package on a range of configurations to look for a pattern of where it works, and where it does not; and/or
  • submit it to the developers responsible for ModelBuilder to undertake detailed analysis, perhaps by inserting additional troubleshooting code.

I just noticed that your question has been updated to say that upgrading to ArcGIS 10.2.2 for Desktop appeared to resolve this for you, and that Esri technical support were unable to reproduce your problem at 10.1. Nevertheless, I'll leave my answer here because I think it offers an alternative to your own onsite testing and troubleshooting when a model you have invested time to develop (and troubleshoot) runs in one supported configuration but fails in another.

  • You could pretty much write this for any ESRI post and I do not think it advances the user in finding a solution to their problem. – If you do not know- just GIS Sep 12 '14 at 16:00
  • Mod or not, go and contact software support is not helpful and does not contribute to the stack as a Q&A format with searchable answers. Just imagine when someone gets this returned with a google search and the answer is contact support. – If you do not know- just GIS Sep 13 '14 at 0:03
  • Yep, nothing has changed it is still a poor answer that goes against the stack principle. Up there with "Google it". Afraid you are going to have to deal with it and move on. – If you do not know- just GIS Sep 16 '14 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.