2

I'm loading a WMS layer in QGIS 2.0.1 using the coordinate reference system SWEREF99 TM EPSG:3006, a Swedish crs. The layer displays in the map but when I zoom in to Sweden using the Zoom in-button I end up somewhere in the Arabian Sea. The server (a GeoServer-instance) supports and serves the layer in EPSG:3006. I've tried different settings for reprojecting but no differnces. In QGIS 1.8 this works perfect on the same layer.

URL: http://geodata.havochvatten.se/geoservices/hav-bakgrundskartor/ows Layer: hav-grundkarta

  • Yes you are right with SWEREF99 TM, it's just for Sweden but we have a background map in EPSG:4326 and when we use it, the zoom doesn't work. I've found one solution to the problem and that is to check the "Invert axis orientation"-checkbox in the connection-dialog. Then it works to zoom. Why is it like this? Can it be problems with WMS-version? WMS 1.3.0 vs. 1.1.1. How – Jonas Dec 11 '13 at 9:12
  • I found out that QGIS 2.0 and 1.8 use version 1.3.0 as default in GetMap requests. If I check the "Invert axis orientation" the map is displayed correctly when zooming in QGIS 2.0. If you explicitly set VERSION = 1.1.1 in the URL the problem does not occur in 2.0. QGIS 1.8 does not have these problems at all since it manages to do this automatically. Why doesn't 2.0 manage to do it automatically? – Jonas Dec 13 '13 at 13:05
2

I can confirm your problem, even with the latest dev versions.

SWEREF is a UTM projection which is not valid for the whole world. Outside of approximately 20° West to 60° East it produces nasty artefacts.

So it makes little use to load a worldwide map in that CRS. Try one of the worldwide projections like EPSG:4326 or EPSG:3857 which are available from the server.

With On-the-fly reprojection it should be no problem to use them in a EPSG:3006 project, as long as you are viewing around Sweden.

0

have you tried the following:

Load the WMS in to QGIS, 4326/WGS84 data frame. Right-click WMS, set layer CRS to 3006 Right-click WMS, set project CRS to Layer

Zoom to extent.

0

This issue is now solved in QGIS 2.2, for details see: https://github.com/qgis/QGIS/pull/1081

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.